summary refs log tree commit diff
path: root/gnu/packages/hexedit.scm
diff options
context:
space:
mode:
authorJakub Kądziołka <kuba@kadziolka.net>2020-01-19 13:44:34 +0100
committerMarius Bakke <mbakke@fastmail.com>2020-01-29 11:03:10 +0100
commit602059e794182a035f3919c3eb88d7d2085e24df (patch)
treef405f8504e69ca9c89d6b0e63b54979a383b64fa /gnu/packages/hexedit.scm
parentd5037890b44a2ac0cc55ef650edf2d52851b421b (diff)
downloadguix-602059e794182a035f3919c3eb88d7d2085e24df.tar.gz
gnu: hexedit: Make F1 help more reliable.
* gnu/packages/hexedit.scm (hexedit)[arguments](patch-man-path): New
phase.
[inputs]: Add MAN-DB.

Signed-off-by: Marius Bakke <mbakke@fastmail.com>
Diffstat (limited to 'gnu/packages/hexedit.scm')
-rw-r--r--gnu/packages/hexedit.scm19
1 files changed, 17 insertions, 2 deletions
diff --git a/gnu/packages/hexedit.scm b/gnu/packages/hexedit.scm
index 365b6dab08..e1a029167a 100644
--- a/gnu/packages/hexedit.scm
+++ b/gnu/packages/hexedit.scm
@@ -25,6 +25,7 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages autotools)
   #:use-module (gnu packages compression)
+  #:use-module (gnu packages man)
   #:use-module (gnu packages ncurses)
   #:use-module (guix download)
   #:use-module (guix git-download)
@@ -44,12 +45,26 @@
                (base32
                 "1xsxa5mip892jkvz9jshj73y6c7j3mgp8y393ciihqlyf2nmfs67"))))
     (build-system gnu-build-system)
-    (arguments '(#:tests? #f))          ; no check target
+    (arguments
+     `(#:tests? #f                      ; no check target
+       #:phases
+       (modify-phases %standard-phases
+         ;; Make F1 open the man page even if man-db is not in the profile.
+         (add-after 'unpack 'patch-man-path
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (substitute* "interact.c"
+               (("\"man\"")
+                (string-append "\"" (assoc-ref inputs "man-db") "/bin/man\""))
+               (("\"hexedit\"")
+                (string-append "\"" (assoc-ref outputs "out")
+                               "/share/man/man1/hexedit.1.gz\"")))
+             #t)))))
     (native-inputs
      `(("autoconf" ,autoconf)
        ("automake" ,automake)))
     (inputs
-     `(("ncurses" ,ncurses)))
+     `(("man-db" ,man-db)
+       ("ncurses" ,ncurses)))
     (synopsis "View and edit files or devices in hexadecimal or ASCII")
     (description "hexedit shows a file both in ASCII and in hexadecimal.  The
 file can be a device as the file is read a piece at a time.  You can modify