summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJosselin Poiret <dev@jpoiret.xyz>2023-05-22 11:04:17 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-07-13 18:20:06 +0200
commit999a6ac0cfd9339e138007ed9e4e544a55e92e3e (patch)
treefb6507d9c720f0f230006f6fa86a13e378c6a55e /gnu/packages/hurd.scm
parent2edd67d34b85715e97b222f4a46da7b156973616 (diff)
downloadguix-999a6ac0cfd9339e138007ed9e4e544a55e92e3e.tar.gz
gnu: mig: Update to 1.8+git20230520.
* gnu/packages/hurd.scm (mig)[source]: Update to 1.8+git20230520.
* gnu/packages/patches/gnumach-add-missing-const_mach_port_name_array_t-type.patch:
Drop patch.
* gnu/local.mk (dist_patch_DATA): Unregister it.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm20
1 files changed, 8 insertions, 12 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 6dc14f25a0..9895955ea2 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -88,24 +88,20 @@
 (define-public mig
   (package
     (name "mig")
-    (version "1.8+git20220827")
+    (version "1.8+git20230520")
     (source (origin
-              (method url-fetch)
-              ;; XXX: Version 2.35 of glibc can only be built with an
-              ;; unreleased version of MiG:
-              ;; <https://lists.gnu.org/archive/html/bug-hurd/2023-03/msg00025.html>.
-              ;; It cannot be fetched from Git though, as the extra dependency
-              ;; on Autoconf/Automake would complicate bootstrapping.
-              (uri (string-append "mirror://gnu/guix/mirror/mig-"
-                                  version ".tar.gz"))
+              (method git-fetch)
+              (uri (git-reference
+                    (url "https://git.savannah.gnu.org/git/hurd/mig.git")
+                    (commit (string-append "v" version))))
+              (file-name (git-file-name name version))
               (sha256
                (base32
-                "163d37s9lscd6zxyfng421m9nl857464mgjj90xsrcl5ykbng5p2"))
-              (patches (search-patches "mig-cpu.h-generation.patch"))))
+                "10r0fdjqjzqsy6ajb21rifvhw0wpjvrw6a1zdyliqlzqny5k0qlz"))))
     (build-system gnu-build-system)
     ;; Flex is needed both at build and run time.
     (inputs (list gnumach-headers flex))
-    (native-inputs (list flex bison))
+    (native-inputs (list autoconf automake flex bison))
     (arguments
      (list #:tests? #f
            #:phases