summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-09-30 22:32:07 +0200
committerRicardo Wurmus <rekado@elephly.net>2021-09-30 22:32:07 +0200
commita76232340a74c3d19d3062b2eab4244eb11b2b7b (patch)
tree03b78cd9482ed58927781dc223b262907cff6579 /gnu/packages/hurd.scm
parent51a9b8fd8f22332e616ad628226e69c175da3f40 (diff)
downloadguix-a76232340a74c3d19d3062b2eab4244eb11b2b7b.tar.gz
gnu: gnumach: Add -fcommon to GCC flags.
* gnu/packages/hurd.scm (gnumach)[arguments]: Add -fcommon GCC flag.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm5
1 files changed, 3 insertions, 2 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 7a1827aa8b..0743bf271c 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -301,6 +301,8 @@ Hurd-minimal package which are needed for both glibc and GCC.")
     (name "gnumach")
     (arguments
      (substitute-keyword-arguments (package-arguments gnumach-headers)
+       ((#:make-flags flags ''())
+        `(cons "CFLAGS=-fcommon" ,flags))
        ((#:configure-flags flags ''())
         `(cons "--enable-kdb" ,flags))            ;enable kernel debugger
        ((#:phases phases '%standard-phases)
@@ -310,8 +312,7 @@ Hurd-minimal package which are needed for both glibc and GCC.")
                (let* ((out  (assoc-ref outputs "out"))
                       (boot (string-append out "/boot")))
                  (invoke "make" "gnumach.gz")
-                 (install-file "gnumach.gz" boot)
-                 #t)))))))
+                 (install-file "gnumach.gz" boot))))))))
     (native-inputs
      `(("mig" ,mig)
        ("perl" ,perl)