summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2023-03-04 16:04:36 +0100
committerLudovic Courtès <ludo@gnu.org>2023-03-04 18:46:37 +0100
commit0b4837a95b255ba18e01b2155ded2c7718bd9181 (patch)
tree02cbbacf2d97727722df214d21b563d57685d0ac /gnu/packages/hurd.scm
parentcfda54c12fb83f8dea4536051ecdbb4dad17632d (diff)
downloadguix-0b4837a95b255ba18e01b2155ded2c7718bd9181.tar.gz
gnu: mig: Remove dependency on Perl.
* gnu/packages/hurd.scm (mig)[inputs]: Remove PERL.
[arguments]: Remove 'patch-non-shebang-references' phase and add
'avoid-perl-dependency' phase.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm15
1 files changed, 8 insertions, 7 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 2c2cbb95ba..f4de5dc6c2 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -122,19 +122,20 @@ GNU/Hurd."
         "1gyda8sq6b379nx01hkpbd85lz39irdvz2b9wbr63gicicx8i706"))))
     (build-system gnu-build-system)
     ;; Flex is needed both at build and run time.
-    (inputs (list gnumach-headers flex perl))
-    (native-inputs
-     (list flex bison))
+    (inputs (list gnumach-headers flex))
+    (native-inputs (list flex bison))
     (arguments
      (list #:tests? #f
            #:phases
            #~(modify-phases %standard-phases
-               (add-after 'install 'patch-non-shebang-references
+               (add-after 'install 'avoid-perl-dependency
                  (lambda* (#:key build inputs outputs #:allow-other-keys)
-                   (let ((perl (assoc-ref inputs "perl"))
-                         (out  (assoc-ref outputs "out")))
+                   (let ((out (assoc-ref outputs "out")))
+                     ;; By default 'mig' uses Perl to compute
+                     ;; 'libexecdir_rel'.  Avoid it.
                      (substitute* (string-append out "/bin/mig")
-                       (("perl ") (string-append perl "/bin/perl ")))))))))
+                       (("^libexecdir_rel=.*")
+                        "libexecdir_rel=../libexec\n"))))))))
     (home-page "https://www.gnu.org/software/hurd/microkernel/mach/mig/gnu_mig.html")
     (synopsis "Mach 3.0 interface generator for the Hurd")
     (description