summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorJanneke Nieuwenhuizen <janneke@gnu.org>2023-05-19 14:03:47 +0200
committerJosselin Poiret <dev@jpoiret.xyz>2023-07-13 18:59:17 +0200
commitbbfb41ed9dff845e12ebd597026729f637903ac4 (patch)
treed4ddc615ca33ca685a8ac300a6d9fa430d827bea /gnu/packages/hurd.scm
parentc22c29b0c4821ebe2c66a6c76562a41d33ff8392 (diff)
downloadguix-bbfb41ed9dff845e12ebd597026729f637903ac4.tar.gz
gnu: gnumach: Support "noide" argument.
* gnu/packages/patches/gnumach-support-noide.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/hurd.scm (gnumach-headers): Use it.
* doc/guix.texi (Bootloader Configuration): Document it.

Signed-off-by: Josselin Poiret <dev@jpoiret.xyz>
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm6
1 files changed, 6 insertions, 0 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 419d12939f..3a9797009b 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -253,6 +253,12 @@ Hurd-minimal package which are needed for both glibc and GCC.")
   (package
     (inherit gnumach-headers)
     (name "gnumach")
+    (source (origin
+              (inherit (package-source gnumach-headers))
+              (patches
+               (append
+                (search-patches "gnumach-support-noide.patch")
+                (origin-patches (package-source gnumach-headers))))))
     (arguments
      (substitute-keyword-arguments (package-arguments gnumach-headers)
        ((#:make-flags flags ''())