summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-04-07 16:55:29 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-11 19:22:27 +0200
commitad3bbeadb46accce9c744f45cf079426b7e9a318 (patch)
tree75c2a2e5b7053315db0c4f7a98b14b8c69f54796 /gnu/packages/hurd.scm
parent1d5fc9f7a70b89c70bfc540ac087d08d5b1943b8 (diff)
downloadguix-ad3bbeadb46accce9c744f45cf079426b7e9a318.tar.gz
gnu: hurd: Install a BDF font.
* gnu/packages/hurd.scm (unifont): New variable.
(hurd)[arguments]: In 'install-goodies' phase, install
OUT/share/hurd/vga-system.bdf.
[inputs]: Add UNIFONT.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm25
1 files changed, 23 insertions, 2 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 620faf30ca..f7c0637f40 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -292,6 +292,17 @@ Hurd-minimal package which are needed for both glibc and GCC.")
     (description
      "GNU Mach is the microkernel upon which a GNU Hurd system is based.")))
 
+(define unifont
+  ;; GNU Unifont, <http://gnu.org/s/unifont>.
+  ;; Used the the VGA driver of the Hurd's console client.
+  (origin
+    (method url-fetch)
+    (uri
+     "http://unifoundry.com/pub/unifont-7.0.06/font-builds/unifont-7.0.06.bdf.gz")
+    (sha256
+     (base32
+      "0p2vhnc18cnbmb39vq4m7hzv4mhnm2l0a2s7gx3ar277fwng3hys"))))
+
 (define (hurd-rc-script)
   "Return a script to be installed as /libexec/rc in the 'hurd' package.  The
 script takes care of installing the relevant passive translators on the first
@@ -413,14 +424,23 @@ fsysopts / --writable\n"))
                          (find-files (string-append out "/libexec")))
                #t)))
          (add-after 'install 'install-goodies
-           (lambda* (#:key outputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              ;; Install additional goodies.
              ;; TODO: Build & install *.msgids for rpctrace.
-             (let ((out (assoc-ref outputs "out")))
+             (let* ((out (assoc-ref outputs "out"))
+                    (datadir (string-append out "/share/hurd")))
                ;; Install the fancy UTF-8 motd.
                (mkdir-p (string-append out "/etc"))
                (copy-file "console/motd.UTF8"
                           (string-append out "/etc/motd"))
+
+               ;; Install the BDF font for use by the console client.
+               (copy-file (assoc-ref inputs "unifont")
+                          "unifont.gz")
+               (invoke "gunzip" "unifont.gz")
+               (mkdir-p datadir)
+               (copy-file "unifont"
+                          (string-append datadir "/vga-system.bdf"))
                #t)))
          (add-after 'install 'install-rc-file
            (lambda* (#:key inputs outputs #:allow-other-keys)
@@ -445,6 +465,7 @@ fsysopts / --writable\n"))
 
        ("libgcrypt" ,libgcrypt)                  ;for /hurd/random
        ("libdaemon" ,libdaemon)                  ;for /bin/console --daemonize
+       ("unifont" ,unifont)
 
        ;; Tools for the /libexec/* scripts.
        ("bash-minimal" ,bash-minimal)