summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2018-03-23 02:42:30 -0400
committerMark H Weaver <mhw@netris.org>2018-03-23 04:42:25 -0400
commita53ced66b1e2d8c5215658806fd34465641b8870 (patch)
treef16b969bd3af58f8ef7e4e50308b7a64a3f54658 /gnu/packages/hurd.scm
parent92fcb831c025a2f4fc58a7c3700d6a1f1a7cb3f5 (diff)
downloadguix-a53ced66b1e2d8c5215658806fd34465641b8870.tar.gz
gnu: gnumach: Use invoke.
* gnu/packages/hurd.scm (gnumach)[arguments]: Use invoke and remove vestigial
plumbing in the 'produce-image' phase.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm7
1 files changed, 3 insertions, 4 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 8dd976ab62..3ab3446d96 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -228,10 +228,9 @@ Hurd-minimal package which are needed for both glibc and GCC.")
                     (lambda* (#:key outputs #:allow-other-keys)
                       (let* ((out  (assoc-ref outputs "out"))
                              (boot (string-append out "/boot")))
-                        (and (zero? (system* "make" "gnumach.gz"))
-                             (begin
-                               (install-file "gnumach.gz" boot)
-                               #t))))))))
+                        (invoke "make" "gnumach.gz")
+                        (install-file "gnumach.gz" boot)
+                        #t))))))
     (native-inputs
      `(("mig" ,mig)
        ("perl" ,perl)))