summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2020-04-14 12:45:15 +0200
committerJan Nieuwenhuizen <janneke@gnu.org>2020-04-26 20:06:28 +0200
commit71b92e1abd015b03ba6ea011ab4129499c1f44c4 (patch)
tree6ce2d5e70b2e711f0b9e76e1d28a9ebd8f506f99 /gnu/packages/hurd.scm
parent706b91ea8ded9118b3f5ef3d0a68ffc6f579f847 (diff)
downloadguix-71b92e1abd015b03ba6ea011ab4129499c1f44c4.tar.gz
gnu: Add dde-sources.
* gnu/packages/hurd.scm (dde-sources): New variable.
(hurd)[native-inputs]: Add it.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm27
1 files changed, 14 insertions, 13 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 88af75c48e..716fd59f75 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -355,6 +355,19 @@ boot, since this cannot be done from GNU/Linux."
   (with-parameters ((%current-target-system "i586-pc-gnu"))
     (program-file "rc" rc)))
 
+(define dde-sources
+  ;; This is the current tip of the dde branch
+  (let ((commit "ac1c7eb7a8b24b7469bed5365be38a968d59a136"))
+    (origin
+      (method git-fetch)
+      (uri (git-reference
+            (url "https://git.savannah.gnu.org/git/hurd/incubator.git")
+            (commit commit)))
+      (sha256
+       (base32
+        "1vryinbg75xpydfrv9dbgfnds6knlh8l8bk2rxp32y9dc58z0692"))
+      (file-name (git-file-name "dde" commit)))))
+
 (define-public hurd
   (package
     (name "hurd")
@@ -508,19 +521,7 @@ fsysopts / --writable\n"))
                    mig))
        ("perl" ,perl)
        ("texinfo" ,texinfo-4)
-       ("dde-sources"
-        ;; This is the current tip of the dde branch
-        ,(let ((commit "ac1c7eb7a8b24b7469bed5365be38a968d59a136"))
-           (origin
-             (method git-fetch)
-             (uri (git-reference
-                   (url "https://git.savannah.gnu.org/git/hurd/incubator.git")
-                   (commit commit)))
-             (sha256
-              (base32
-               "1vryinbg75xpydfrv9dbgfnds6knlh8l8bk2rxp32y9dc58z0692"))
-             (file-name (string-append "dde-checkout-"
-                                       (string-take commit 7))))))))
+       ("dde-sources" ,dde-sources)))
     (supported-systems %hurd-systems)
     (home-page "https://www.gnu.org/software/hurd/hurd.html")
     (synopsis "The kernel servers for the GNU operating system")