summary refs log tree commit diff
path: root/gnu/packages/hurd.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2020-03-31 23:44:25 +0200
committerLudovic Courtès <ludo@gnu.org>2020-04-01 00:12:31 +0200
commite62f6f77fe1c1823e8f927d582554eda436234c1 (patch)
treeacf647e3603d05cc4d7eff1e56a766e0f78227a2 /gnu/packages/hurd.scm
parentb87d7002b7ef1184641b97fa601aa594a5d3af76 (diff)
downloadguix-e62f6f77fe1c1823e8f927d582554eda436234c1.tar.gz
gnu: gnumach: Fix compilation.
* gnu/packages/hurd.scm (gnumach)[arguments]: Inherit arguments from
GNUMACH-HEADERS.
[native-inputs]: Add AUTOCONF, AUTOMAKE, and TEXINFO-4.
Diffstat (limited to 'gnu/packages/hurd.scm')
-rw-r--r--gnu/packages/hurd.scm25
1 files changed, 15 insertions, 10 deletions
diff --git a/gnu/packages/hurd.scm b/gnu/packages/hurd.scm
index 3d1709fcc3..d483badbc5 100644
--- a/gnu/packages/hurd.scm
+++ b/gnu/packages/hurd.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014, 2015, 2016, 2017 Manolis Fragkiskos Ragkousis <manolis837@gmail.com>
-;;; Copyright © 2018 Ludovic Courtès <ludo@gnu.org>
+;;; Copyright © 2018, 2020 Ludovic Courtès <ludo@gnu.org>
 ;;; Copyright © 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
@@ -254,17 +254,22 @@ Hurd-minimal package which are needed for both glibc and GCC.")
     (inherit gnumach-headers)
     (name "gnumach")
     (arguments
-     `(#:phases (modify-phases %standard-phases
-                  (add-after 'install 'produce-image
-                    (lambda* (#:key outputs #:allow-other-keys)
-                      (let* ((out  (assoc-ref outputs "out"))
-                             (boot (string-append out "/boot")))
-                        (invoke "make" "gnumach.gz")
-                        (install-file "gnumach.gz" boot)
-                        #t))))))
+     (substitute-keyword-arguments (package-arguments gnumach-headers)
+       ((#:phases phases '%standard-phases)
+        `(modify-phases %standard-phases
+           (add-after 'install 'produce-image
+             (lambda* (#:key outputs #:allow-other-keys)
+               (let* ((out  (assoc-ref outputs "out"))
+                      (boot (string-append out "/boot")))
+                 (invoke "make" "gnumach.gz")
+                 (install-file "gnumach.gz" boot)
+                 #t)))))))
     (native-inputs
      `(("mig" ,mig)
-       ("perl" ,perl)))
+       ("perl" ,perl)
+       ("autoconf" ,autoconf)
+       ("automake" ,automake)
+       ("texinfo" ,texinfo-4)))
     (supported-systems (cons "i686-linux" %hurd-systems))
     (synopsis "Microkernel of the GNU system")
     (description