summary refs log tree commit diff
path: root/gnu/packages/hyperledger.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-03 15:06:55 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-11-06 00:08:04 -0400
commit451d2802f6471d1a5f2eea08ae7ce2ad8747f797 (patch)
tree4713e5eb96f9efd7a0adb3587368600c64634f25 /gnu/packages/hyperledger.scm
parent76b86238acbe462427df670a287b004cbc9a49af (diff)
downloadguix-451d2802f6471d1a5f2eea08ae7ce2ad8747f797.tar.gz
gnu: fmt: Update to 9.1.0.
* gnu/packages/pretty-print.scm (fmt): Update to 9.1.0.
(fmt-8): New variable.
* gnu/packages/hyperledger.scm (hyperledger-iroha)
[snippet]: Delete trailing  #t.
[native-inputs]: Re-indent.  Replace fmt with fmt-8.
* gnu/packages/networking.scm (opendht) [inputs]: Replace fmt with fmt-8.
* gnu/packages/storage.scm (ceph): Likewise.
* gnu/packages/video.scm (mkvtoolnix): Likewise.
* gnu/packages/aidc.scm (zxing-cpp): Likewise.
* gnu/packages/wm.scm (waybar): Likewise.
* gnu/packages/geo.scm (osm2pgsql): Likewise.
* gnu/packages/graphics.scm (openimageio): Likewise.
* gnu/packages/build-tools.scm (bear): Likewise.
* gnu/packages/networking.scm (restinio): Likewise.
Diffstat (limited to 'gnu/packages/hyperledger.scm')
-rw-r--r--gnu/packages/hyperledger.scm9
1 files changed, 6 insertions, 3 deletions
diff --git a/gnu/packages/hyperledger.scm b/gnu/packages/hyperledger.scm
index 2a4b87e927..45436da7db 100644
--- a/gnu/packages/hyperledger.scm
+++ b/gnu/packages/hyperledger.scm
@@ -166,8 +166,7 @@ link-time.  New implementations can be added as well.")
                   ;; https://github.com/hyperledger/iroha/commit/4dc710d2e9a067af866771318f673c7392797e48
                   ;; Backport unversioned fmt dependency, remove next update:
                   (substitute* "libs/logger/logger.hpp"
-                    (("fmt::v5") "fmt"))
-                  #t))))
+                    (("fmt::v5") "fmt"))))))
     (build-system cmake-build-system)
     (arguments
      `(#:configure-flags
@@ -179,7 +178,11 @@ link-time.  New implementations can be added as well.")
        #:test-target "."))
     ;; https://github.com/hyperledger/iroha/blob/master/vcpkg/VCPKG_DEPS_LIST
     (native-inputs
-     (list fmt googletest rapidjson rxcpp spdlog))
+     (list fmt-8
+           googletest
+           rapidjson
+           rxcpp
+           spdlog))
     (inputs
      (list boost
            gflags