summary refs log tree commit diff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2017-05-09 21:48:54 +0200
committerRicardo Wurmus <rekado@elephly.net>2017-05-15 22:33:16 +0200
commit1d4234d4c252983bee3363e11fc26a2de56682b1 (patch)
tree1ef88715bd0acf298595b93e9185637b4e617cfc /gnu/packages/icu4c.scm
parent6636f6388f5ad02bd4e4953972a03d05bcd1e65e (diff)
downloadguix-1d4234d4c252983bee3363e11fc26a2de56682b1.tar.gz
gnu: Add java-icu4j.
* gnu/packages/icu4c.scm (java-icu4j): New variable.
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm29
1 files changed, 29 insertions, 0 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 9f465b1022..3e96520054 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -3,6 +3,7 @@
 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Clément Lassieur <clement@lassieur.org>
+;;; Copyright © 2017 Ricardo Wurmus <rekado@elephly.net>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -25,6 +26,7 @@
   #:use-module (guix licenses)
   #:use-module (guix packages)
   #:use-module (guix download)
+  #:use-module (guix build-system ant)
   #:use-module (guix build-system gnu))
 
 (define-public icu4c
@@ -75,3 +77,30 @@ C/C++ part.")
               (patches
                (search-patches "icu4c-CVE-2017-7867-CVE-2017-7868.patch"
                                "icu4c-reset-keyword-list-iterator.patch"))))))
+
+(define-public java-icu4j
+  (package
+    (name "java-icu4j")
+    (version "59.1")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "http://download.icu-project.org/files/icu4j/"
+                                  version "/icu4j-"
+                                  (string-map (lambda (x)
+                                                (if (char=? x #\.) #\_ x))
+                                              version)
+                                  "-src.jar"))
+              (sha256
+               (base32
+                "0bgxsvgi0qcwj60pvcxrf7a3fbk7aksyxnfwpbzavyfrfzixqh0c"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:tests? #f                      ; no tests included
+       #:jar-name "icu4j.jar"))
+    (home-page "http://site.icu-project.org/")
+    (synopsis "International Components for Unicode")
+    (description
+     "ICU is a set of C/C++ and Java libraries providing Unicode and
+globalisation support for software applications.  This package contains the
+Java part.")
+    (license x11)))