summary refs log tree commit diff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2016-11-26 22:16:16 +0200
committerEfraim Flashner <efraim@flashner.co.il>2016-11-27 09:24:40 +0200
commit5499de02ca265745b98ddcc40af087dfaa14c9ba (patch)
tree45bad37583741d65eff70cae036313d85b74056b /gnu/packages/icu4c.scm
parente30abbbb02583021eaf7f0533f234ea92f291d55 (diff)
downloadguix-5499de02ca265745b98ddcc40af087dfaa14c9ba.tar.gz
gnu: icu4c: Update to 58.1.
* gnu/packages/icu4c.scm (icu4c): Update to 58.1.
[source]: Download from their website.
[arguments]: Remove extra bash replacement.
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm20
1 files changed, 5 insertions, 15 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 13723bf585..18de81f4ad 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -1,6 +1,7 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2013 Andreas Enge <andreas@enge.fr>
 ;;; Copyright © 2015, 2016 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -28,20 +29,17 @@
 (define-public icu4c
   (package
    (name "icu4c")
-   (version "55.1")
+   (version "58.1")
    (source (origin
             (method url-fetch)
             (uri (string-append
-                  "mirror://sourceforge/icu/ICU4C/"
+                  "http://download.icu-project.org/files/icu4c/"
                   version
                   "/icu4c-"
                   (string-map (lambda (x) (if (char=? x #\.) #\_ x)) version)
                   "-src.tgz"))
             (sha256
-             (base32 "0ys5f5spizg45qlaa31j2lhgry0jka2gfha527n4ndfxxz5j4sz1"))
-            (patches (search-patches "icu4c-CVE-2014-6585.patch"
-                                     "icu4c-CVE-2015-1270.patch"
-                                     "icu4c-CVE-2015-4760.patch"))))
+             (base32 "0283lcgb39v7hsl16bbp8h8r9d51n4lpld5dr292173afjinpd0f"))))
    (build-system gnu-build-system)
    (inputs
     `(("perl" ,perl)))
@@ -58,15 +56,7 @@
       (alist-cons-after
        'unpack 'chdir-to-source
        (lambda _ (chdir "source"))
-       (alist-cons-before
-        'configure 'patch-configure
-        (lambda _
-          ;; patch out two occurrences of /bin/sh from configure script
-          ;; that might have disappeared in a release later than 54.1
-          (substitute* "configure"
-            (("`/bin/sh")
-             (string-append "`" (which "bash")))))
-        %standard-phases))))
+        %standard-phases)))
    (synopsis "International Components for Unicode")
    (description
     "ICU is a set of C/C++ and Java libraries providing Unicode and