summary refs log tree commit diff
path: root/gnu/packages/icu4c.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-07-23 19:11:33 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-07-31 14:41:35 +0200
commitf73fe13ccd1ef3fe6f6e0409fa817e5feb612e40 (patch)
tree964a91765022f545aa97e3011a888ec143ef98d7 /gnu/packages/icu4c.scm
parent7999d317bcc12d9c1ebc63bd519145ee4954e410 (diff)
downloadguix-f73fe13ccd1ef3fe6f6e0409fa817e5feb612e40.tar.gz
gnu: icu4c: Make 'libicudata.so' behave the same on all architectures.
* gnu/packages/icu4c.scm (icu4c)[arguments]: Do not pass
'--with-data-packaging=archive' in #:configure-flags.  Add phase to enable use
of standard libraries in libicudata.so.
Diffstat (limited to 'gnu/packages/icu4c.scm')
-rw-r--r--gnu/packages/icu4c.scm16
1 files changed, 9 insertions, 7 deletions
diff --git a/gnu/packages/icu4c.scm b/gnu/packages/icu4c.scm
index 258721963b..922dfbd348 100644
--- a/gnu/packages/icu4c.scm
+++ b/gnu/packages/icu4c.scm
@@ -76,17 +76,19 @@
     `(("perl" ,perl)))
    (arguments
     `(#:configure-flags
-      '("--enable-rpath"
-        ,@(if (let ((s (or (%current-target-system)
-                           (%current-system))))
-                (or (string-prefix? "arm" s)
-                    (string-prefix? "mips" s)))
-              '("--with-data-packaging=archive")
-              '()))
+      '("--enable-rpath")
       #:phases
       (modify-phases %standard-phases
         (add-after 'unpack 'chdir-to-source
           (lambda _ (chdir "source") #t))
+        (add-after 'chdir-to-source 'update-LDFLAGS
+          (lambda _
+            ;; Do not create a "data-only" libicudata.so because it causes
+            ;; problems on some architectures (notably armhf and MIPS).
+            (substitute* "config/mh-linux"
+              (("LDFLAGSICUDT=-nodefaultlibs -nostdlib")
+               "LDFLAGSICUDT="))
+            #t))
         (add-after 'install 'avoid-coreutils-reference
           ;; Don't keep a reference to the build tools.
           (lambda* (#:key outputs #:allow-other-keys)