summary refs log tree commit diff
path: root/gnu/packages/image-processing.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <ricardo.wurmus@mdc-berlin.de>2019-08-13 17:46:22 +0200
committerRicardo Wurmus <rekado@elephly.net>2019-08-15 14:09:13 +0200
commit02e1acfb2a65783d63e526da798337c91b40a5f1 (patch)
tree4d3ef343508f1b8d62034f6c26ae0fa558f2d8ee /gnu/packages/image-processing.scm
parent18696f7acfed09272eb9a35d2ad27d8a8e534384 (diff)
downloadguix-02e1acfb2a65783d63e526da798337c91b40a5f1.tar.gz
gnu: Add vxl.
* gnu/packages/image-processing.scm (vxl): New variable.
Diffstat (limited to 'gnu/packages/image-processing.scm')
-rw-r--r--gnu/packages/image-processing.scm43
1 files changed, 43 insertions, 0 deletions
diff --git a/gnu/packages/image-processing.scm b/gnu/packages/image-processing.scm
index 6680d65283..a4365f6009 100644
--- a/gnu/packages/image-processing.scm
+++ b/gnu/packages/image-processing.scm
@@ -40,6 +40,7 @@
   #:use-module (gnu packages documentation)
   #:use-module (gnu packages flex)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages geo)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
   #:use-module (gnu packages glib)
@@ -534,3 +535,45 @@ the VIPS image processing library.  It's a little like a spreadsheet: you
 create a set of formula connecting your objects together, and on a change nip2
 recalculates.")
     (license license:gpl2+)))
+
+(define-public vxl
+  (package
+    (name "vxl")
+    (version "2.0.2")
+    (source
+     (origin
+       (method git-fetch)
+       (uri (git-reference
+             (url "https://github.com/vxl/vxl.git")
+             (commit (string-append "v" version))))
+       (file-name (git-file-name name version))
+       (sha256
+        (base32 "0949hw57szq8943f1whwqaz591xjmb19kj803hcv74hdai2b0ycg"))
+       (modules '((guix build utils)))
+       ;; TODO: vxl includes an old version of dcmtk.  It won't build with
+       ;; version 3.6.x.
+       (snippet
+        '(begin
+           (for-each delete-file-recursively
+                     '("v3p/bzlib/"
+                       "v3p/geotiff/"
+                       "v3p/jpeg/"
+                       "v3p/png/"
+                       "v3p/tiff/"
+                       "v3p/zlib/"))
+           (substitute* "v3p/CMakeLists.txt"
+             (("add_subdirectory\\((tiff|png|jpeg|zlib|bzlib|geotiff)\\)")
+              ""))
+           #t))))
+    (build-system cmake-build-system)
+    (inputs
+     `(("libgeotiff" ,libgeotiff)
+       ("libtiff" ,libtiff)
+       ("libjpeg" ,libjpeg)
+       ("libpng" ,libpng)
+       ("zlib" ,zlib)))
+    (home-page "https://github.com/vxl/vxl/")
+    (synopsis "Collection of C++ libraries for computer vision")
+    (description "VXL (the Vision-something-Libraries) is a collection of C++
+libraries designed for computer vision research and implementation.")
+    (license license:bsd-3)))