summary refs log tree commit diff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorMathieu Othacehe <m.othacehe@gmail.com>2017-04-10 20:33:22 +0200
committerLudovic Courtès <ludo@gnu.org>2017-04-10 23:54:46 +0200
commited3a9ec5acfb96cf79ede69b96ecc396d2312185 (patch)
tree8acfa32dd78516cd250749929d6de0f9dafad975 /gnu/packages/image-viewers.scm
parenta97f0ee1368499dc40ea30002fcb6e06c7880acb (diff)
downloadguix-ed3a9ec5acfb96cf79ede69b96ecc396d2312185.tar.gz
gnu: Add gpicview.
* gnu/packages/image-viewers.scm (gpicview): New variable.
* gnu/packages/lxde.scm (lxde)[propagated-inputs]: Add gpicview.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm24
1 files changed, 24 insertions, 0 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index ce75b1d835..a7e108a292 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -5,6 +5,7 @@
 ;;; Copyright © 2016 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2017 Alex Griffin <a@ajgrf.com>
 ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
+;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -122,6 +123,29 @@ image formats; tools for image comparison, sorting and managing photo
 collection.  Geeqie was initially based on GQview.")
     (license license:gpl2+)))
 
+(define-public gpicview
+  (package
+    (name "gpicview")
+    (version "0.2.5")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/lxde/"
+                                  "GPicView%20%28image%20Viewer%29/0.2.x/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "0hi9v0rdx47nys0wvm9xasdrafa34r5kq6crb074a0ipwmc60iiq"))))
+    (build-system gnu-build-system)
+    (inputs `(("gtk+" ,gtk+-2)
+              ("libjpeg" ,libjpeg)))
+    (native-inputs `(("intltool"   ,intltool)
+                     ("pkg-config" ,pkg-config)))
+    (synopsis "Simple and fast image viewer for X")
+    (description "gpicview is a lightweight GTK+ 2.x based image viewer.
+It is the default image viewer on LXDE desktop environment.")
+    (home-page "http://lxde.sourceforge.net/gpicview/")
+    (license license:gpl2+)))
+
 (define-public sxiv
   (package
     (name "sxiv")