summary refs log tree commit diff
path: root/gnu/packages/image-viewers.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2018-01-17 16:16:21 +0100
committerTobias Geerinckx-Rice <me@tobias.gr>2018-01-17 16:16:58 +0100
commit6c162d0e5283b9e116e3a6f1fd405362237e5a9e (patch)
tree82c7d245fdd1b5fada3438712f4d5a0bebb59aec /gnu/packages/image-viewers.scm
parentba4919122aa9b3897f491935cd2d6ae450e5d040 (diff)
downloadguix-6c162d0e5283b9e116e3a6f1fd405362237e5a9e.tar.gz
gnu: sxiv: Update to 24.
* gnu/packages/image-viewers.scm (sxiv): Update to 24.
[inputs]: Add freetype and libxft.
[arguments]: Pass freetype header location in #:make-flags.  Be verbose.
Diffstat (limited to 'gnu/packages/image-viewers.scm')
-rw-r--r--gnu/packages/image-viewers.scm32
1 files changed, 22 insertions, 10 deletions
diff --git a/gnu/packages/image-viewers.scm b/gnu/packages/image-viewers.scm
index e267eb2081..f07b30805e 100644
--- a/gnu/packages/image-viewers.scm
+++ b/gnu/packages/image-viewers.scm
@@ -7,6 +7,7 @@
 ;;; Copyright © 2017 ng0 <contact.ng0@cryptolab.net>
 ;;; Copyright © 2017 Mathieu Othacehe <m.othacehe@gmail.com>
 ;;; Copyright © 2017 nee <nee-git@hidamari.blue>
+;;; Copyright © 2018 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -36,6 +37,7 @@
   #:use-module (gnu packages boost)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages curl)
+  #:use-module (gnu packages fontutils)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages glib)
   #:use-module (gnu packages gnome)
@@ -176,7 +178,7 @@ It is the default image viewer on LXDE desktop environment.")
 (define-public sxiv
   (package
     (name "sxiv")
-    (version "1.3.2")
+    (version "24")
     (source (origin
               (method url-fetch)
               (uri (string-append
@@ -185,19 +187,29 @@ It is the default image viewer on LXDE desktop environment.")
               (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "0lxnd33gaw4drhdwbkk94wzrjyhh64d57jq2ps7ffmqgizg6hlwz"))))
+                "044i077li6m4zsz2fswlcdi2m0sbr9mwws1h3k1zjaln29fw87ai"))))
     (build-system gnu-build-system)
     (arguments
-     '(#:tests? #f                      ; no check target
-       #:make-flags (list (string-append "PREFIX=" %output)
-                          "CC=gcc")
-       ;; no configure phase
-       #:phases (modify-phases %standard-phases (delete 'configure))))
+     `(#:tests? #f                      ; no check target
+       #:make-flags
+       (list (string-append "PREFIX=" %output)
+             "CC=gcc"
+             ;; Xft.h #includes <ft2build.h> (without ‘freetype2/’).  The sxiv
+             ;; Makefile works around this by hard-coding /usr/include instead.
+             (string-append "DEF_CPPFLAGS=-I"
+                            (assoc-ref %build-inputs "freetype")
+                            "/include/freetype2")
+             "V=1")
+       #:phases
+       (modify-phases %standard-phases
+         (delete 'configure))))         ; no configure script
     (inputs
-     `(("libx11" ,libx11)
-       ("imlib2" ,imlib2)
+     `(("freetype" ,freetype)
        ("giflib" ,giflib)
-       ("libexif" ,libexif)))
+       ("imlib2" ,imlib2)
+       ("libexif" ,libexif)
+       ("libx11" ,libx11)
+       ("libxft" ,libxft)))
     (home-page "https://github.com/muennich/sxiv")
     (synopsis "Simple X Image Viewer")
     (description