summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorArun Isaac <arunisaac@systemreboot.net>2022-07-26 00:41:32 +0530
committerArun Isaac <arunisaac@systemreboot.net>2022-07-26 00:43:31 +0530
commitf55e83fa3dd249591551fa4dfe367c8e5204da03 (patch)
tree1cdc7d068d87c475cc6b5e36fd9ea1eeccf2b78e /gnu/packages/image.scm
parente78bb31aa14a29ddda35a5b4aa28e3633154bd03 (diff)
downloadguix-f55e83fa3dd249591551fa4dfe367c8e5204da03.tar.gz
gnu: phockup: Make exiftool substitution more specific.
* gnu/packages/image.scm (phockup)[arguments]: Make exiftool substitution in
configure phase more specific.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm6
1 files changed, 3 insertions, 3 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index d52d57b3b1..f2bcf13d0f 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -11,7 +11,7 @@
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020, 2021, 2022 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016–2022 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
-;;; Copyright © 2016, 2017, 2020, 2021 Arun Isaac <arunisaac@systemreboot.net>
+;;; Copyright © 2016, 2017, 2020, 2021, 2022 Arun Isaac <arunisaac@systemreboot.net>
 ;;; Copyright © 2016, 2017 Kei Kebreau <kkebreau@posteo.net>
 ;;; Copyright © 2017 Nikita <nikita@n0.is>
 ;;; Copyright © 2017,2019,2020 Hartmut Goebel <h.goebel@crazy-compilers.com>
@@ -2402,8 +2402,8 @@ Wacom-style graphics tablets.")
          (add-after 'unpack 'configure
            (lambda* (#:key inputs #:allow-other-keys)
              (substitute* (list "src/dependency.py" "src/exif.py")
-               (("exiftool")
-                (search-input-file inputs "/bin/exiftool")))))
+               (("'exiftool'")
+                (string-append "'" (search-input-file inputs "/bin/exiftool") "'")))))
          (add-before 'install 'check
            (lambda _
              (invoke "pytest")))