summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-06-25 16:50:52 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-06-25 17:22:11 +0200
commit0e1c5ccc3b7ac988f69988b8adf499e89b133856 (patch)
tree7b0bb0ccd76e865df1e96bdef82c78ecf28f6fa3 /gnu/packages/image.scm
parent8cba7d2a996f82c99a00218ffe05766bd4c08fec (diff)
downloadguix-0e1c5ccc3b7ac988f69988b8adf499e89b133856.tar.gz
gnu: exiv2: Update to 0.27.1.
* gnu/packages/image.scm (exiv2): Update to 0.27.1.
[build-system]: Switch to the CMAKE-BUILD-SYSTEM.
[native-inputs]: Remove unused intltool.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm28
1 files changed, 10 insertions, 18 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index f9709e2b19..ef477fa6f1 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1040,27 +1040,19 @@ channels.")
 (define-public exiv2
   (package
     (name "exiv2")
-    (version "0.26")
-    (source (origin
-             (method url-fetch)
-             (uri (list (string-append "https://www.exiv2.org/builds/exiv2-"
-                                       version "-trunk.tar.gz")
-                        (string-append "https://www.exiv2.org/exiv2-"
-                                       version ".tar.gz")
-                        (string-append "https://fossies.org/linux/misc/exiv2-"
-                                       version ".tar.gz")))
-             (patches (search-patches "exiv2-CVE-2017-14860.patch"
-                                      "exiv2-CVE-2017-14859-14862-14864.patch"))
-             (sha256
-              (base32
-               "1yza317qxd8yshvqnay164imm0ks7cvij8y8j86p1gqi1153qpn7"))))
-    (build-system gnu-build-system)
-    (arguments '(#:tests? #f))                    ; no `check' target
+    (version "0.27.1")
+    (source
+     (origin
+       (method url-fetch)
+       (uri (string-append "https://www.exiv2.org/builds/exiv2-" version
+                           "-Source.tar.gz"))
+       (sha256
+        (base32 "109hbfk63dh14fz20ivq20gcclb9jj9jmh48w4lcn6zxh1ljh9gi"))))
+    (build-system cmake-build-system)
+    (arguments '(#:tests? #f))          ; no test suite
     (propagated-inputs
      `(("expat" ,expat)
        ("zlib" ,zlib)))
-    (native-inputs
-     `(("intltool" ,intltool)))
     (home-page "https://www.exiv2.org/")
     (synopsis "Library and command-line utility to manage image metadata")
     (description