summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-21 10:35:43 +0100
committerNicolas Goaziou <mail@nicolasgoaziou.fr>2021-02-21 10:35:43 +0100
commit0c6f1b1a6d78f1a59c030378a25d0346333bd40b (patch)
tree3fb006ae318b793e63f006d5369cc66a59704fc5 /gnu/packages/image.scm
parent5fb1bff1ca49f01245ef977d317f13ca69eb6a4f (diff)
downloadguix-0c6f1b1a6d78f1a59c030378a25d0346333bd40b.tar.gz
gnu: exiv2-0.26: Remove variable.
* gnu/packages/image.scm (exiv2-0.26): Remove variable.
* gnu/packages/patches/exiv2-CVE-2017-14859-14862-14864.patch:
* gnu/packages/patches/exiv2-CVE-2017-14860.patch: Remove files.
* gnu/local.mk (dist_patch_DATA): Apply removal.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm28
1 files changed, 0 insertions, 28 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 68221afff1..2d83313d9e 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -1352,34 +1352,6 @@ and XMP metadata of images in various formats.")
     ;;   <https://launchpad.net/ubuntu/precise/+source/exiv2/+copyright>.
     (license license:gpl2+)))
 
-(define-public exiv2-0.26
-  (package
-    (inherit exiv2)
-    (version "0.26")
-    (source (origin
-             (method url-fetch)
-             (uri (list (string-append "https://www.exiv2.org/builds/exiv2-"
-                                       version "-trunk.tar.gz")
-                        (string-append "https://www.exiv2.org/exiv2-"
-                                       version ".tar.gz")
-                        (string-append "https://fossies.org/linux/misc/exiv2-"
-                                       version ".tar.gz")))
-             (patches (search-patches "exiv2-CVE-2017-14860.patch"
-                                      "exiv2-CVE-2017-14859-14862-14864.patch"))
-             (sha256
-              (base32
-               "1yza317qxd8yshvqnay164imm0ks7cvij8y8j86p1gqi1153qpn7"))))
-    (build-system gnu-build-system)
-    (arguments '(#:tests? #f))                    ; no `check' target
-    (propagated-inputs
-     `(("expat" ,expat)
-       ("zlib" ,zlib)))
-    (native-inputs
-     `(("intltool" ,intltool)))
-
-    ;; People should rely on the newer version, so don't expose it.
-    (properties `((hidden? . #t)))))
-
 (define-public devil
   (package
     (name "devil")