summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2020-05-04 16:21:06 +0200
committerMarius Bakke <mbakke@fastmail.com>2020-05-04 16:24:43 +0200
commit08dfff747b2f6e11ed9b12a6a09cfa0178ec8083 (patch)
tree8035d9f50c9baffc2d798e8bba28e0b2a194d60f /gnu/packages/image.scm
parent1c60bd324402290133e17e132ffd92cf78590e8b (diff)
downloadguix-08dfff747b2f6e11ed9b12a6a09cfa0178ec8083.tar.gz
gnu: leptonica: Add giflib reference in Libtool- and pkg-config files.
* gnu/packages/image.scm (leptonica)[arguments]: Add phase
"provide-absolute-giflib-reference".
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm11
1 files changed, 10 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 3f758b779d..eef73d68ab 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -612,7 +612,16 @@ collection of tools for doing simple manipulations of TIFF images.")
                 (string-append " " (which "sh") " "))
                (("which gnuplot")
                 "true"))
-             #t)))))
+             #t))
+         (add-after 'install 'provide-absolute-giflib-reference
+           (lambda* (#:key inputs outputs #:allow-other-keys)
+             (let ((out (assoc-ref outputs "out"))
+                   (giflib (assoc-ref inputs "giflib")))
+               ;; Add an absolute reference to giflib to avoid propagation.
+               (with-directory-excursion (string-append out "/lib")
+                 (substitute* '("liblept.la" "pkgconfig/lept.pc")
+                   (("-lgif") (string-append "-L" giflib "/lib -lgif"))))
+               #t))))))
     (home-page "http://www.leptonica.com/")
     (synopsis "Library and tools for image processing and analysis")
     (description