summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-04-22 12:18:31 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-04-22 12:20:15 +0300
commitf347c24acc14e080dc2801561edca0d525a90257 (patch)
tree0030ec7530b6b3d4e9e2fc50970f7f91408597c9 /gnu/packages/image.scm
parentf1104d900978900addad731dfec4e0e6e5765fbe (diff)
downloadguix-f347c24acc14e080dc2801561edca0d525a90257.tar.gz
gnu: freeimage: Use bundled libjxr.
* gnu/packages/image.scm (freeimage)[source]: Don't delete bundled
LibJXR directory.
[arguments]: Modify make-flags to not include external jxrlib.
[inputs]: Remove libjxr.
* gnu/packages/patches/freeimage-unbundle.patch: Modify to not unbundle
libjxr.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm8
1 files changed, 5 insertions, 3 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index e27b9223dd..7ed18cf1a6 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -724,7 +724,8 @@ supplies a generic doubly-linked list and some string functions.")
                 (for-each
                   (lambda (dir)
                     (delete-file-recursively (string-append "Source/" dir)))
-                  '("LibJPEG" "LibJXR" "LibOpenJPEG" "LibPNG" "LibRawLite"
+                  '("LibJPEG" "LibOpenJPEG" "LibPNG" "LibRawLite"
+                    ;; "LibJXR"
                     "LibWebP" "OpenEXR" "ZLib"))))
             (patches (search-patches "freeimage-unbundle.patch"
                                      "freeimage-CVE-2015-0852.patch"
@@ -760,14 +761,15 @@ supplies a generic doubly-linked list and some string functions.")
             ;; We need '-fpermissive' for Source/FreeImage.h.
             ;; libjxr doesn't have a pkg-config file.
             (string-append "CFLAGS+=-O2 -fPIC -fvisibility=hidden -fpermissive "
-                           "-I" (assoc-ref %build-inputs "libjxr") "/include/jxrlib"))
+                           ;"-I" (assoc-ref %build-inputs "libjxr") "/include/jxrlib"
+                           ))
       #:tests? #f)) ; no check target
    (native-inputs
     `(("pkg-config" ,pkg-config)
       ("unzip" ,unzip)))
    (inputs
     `(("libjpeg" ,libjpeg)
-      ("libjxr" ,libjxr)
+      ;("libjxr" ,libjxr)
       ("libpng" ,libpng)
       ("libraw" ,libraw)
       ("libtiff" ,libtiff)