summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarek Benc <merkur32@gmail.com>2014-09-09 11:48:44 +0200
committerLudovic Courtès <ludo@gnu.org>2014-09-09 11:48:44 +0200
commitefa77baf26621277c57b42af1b11078c8a814340 (patch)
tree52c3e2c83389d309525a39b3b570e13794e2608a /gnu/packages/image.scm
parentb005157c9b3a927431b9170b71d828a96507e136 (diff)
downloadguix-efa77baf26621277c57b42af1b11078c8a814340.tar.gz
gnu: Add libwmf.
* gnu/packages/image.scm (libwmf): New variable.

Signed-off-by: Ludovic Courtès <ludo@gnu.org>
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 014266cbb0..6a81143bda 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -20,6 +20,9 @@
   #:use-module (gnu packages)
   #:use-module (gnu packages compression)
   #:use-module (gnu packages file)
+  #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages pkg-config)
+  #:use-module (gnu packages xml)
   #:use-module ((guix licenses) #:renamer (symbol-prefix-proc 'license:))
   #:use-module (guix packages)
   #:use-module (guix download)
@@ -120,3 +123,39 @@ collection of tools for doing simple manipulations of TIFF images.")
    (license (license:bsd-style "file://COPYRIGHT"
                                "See COPYRIGHT in the distribution."))
    (home-page "http://www.libtiff.org/")))
+
+(define-public libwmf
+  (package
+    (name "libwmf")
+    (version "0.2.8.4")
+    (source
+      (origin
+        (method url-fetch)
+        (uri
+          (string-append
+            "http://sourceforge.net/projects/wvware/files/" name "/" version
+            "/" name "-" version ".tar.gz/download"))
+        (file-name
+          (string-append name "-" version ".tar.gz"))
+        (sha256
+          (base32 "1y3wba4q8pl7kr51212jwrsz1x6nslsx1gsjml1x0i8549lmqd2v"))))
+
+    (build-system gnu-build-system)
+    (inputs
+      `(("freetype" ,freetype)
+        ("libjpeg" ,libjpeg)
+        ("libpng",libpng)
+        ("libxml2" ,libxml2)
+        ("zlib" ,zlib)))
+    (native-inputs
+      `(("pkg-config" ,pkg-config)))
+    (synopsis "Library for reading images in the Microsoft WMF format")
+    (description
+      "libwmf is a library for reading vector images in Microsoft's native
+Windows Metafile Format (WMF) and for either (a) displaying them in, e.g., an X
+window; or (b) converting them to more standard/free file formats such as, e.g.,
+the W3C's XML-based Scaleable Vector Graphic (SVG) format.")
+    (home-page "http://wvware.sourceforge.net/libwmf.html")
+
+    ;; 'COPYING' is the GPLv2, but file headers say LGPLv2.0+.
+    (license license:lgpl2.0+)))