summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
author宋文武 <iyzsong@gmail.com>2015-10-27 21:47:37 +0800
committer宋文武 <iyzsong@gmail.com>2015-10-27 21:47:37 +0800
commitbce5ae1d2651b06bf1ce4f8ada324e6e22dd3168 (patch)
tree0391af5d24c2cea2222da9d0b11a597fbd13dfed /gnu/packages/image.scm
parentd8c317df261507ab6fe9ce58f0148ff71db3a24d (diff)
downloadguix-bce5ae1d2651b06bf1ce4f8ada324e6e22dd3168.tar.gz
gnu: leptonica: Update to 1.72.
* gnu/packages/image.scm (leptonica): Update to 1.72.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm7
1 files changed, 4 insertions, 3 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 5a86beea3f..c666674318 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -184,14 +184,14 @@ the W3C's XML-based Scaleable Vector Graphic (SVG) format.")
 (define-public leptonica
   (package
     (name "leptonica")
-    (version "1.71")
+    (version "1.72")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "http://www.leptonica.com/source/leptonica-"
                            version ".tar.gz"))
        (sha256
-        (base32 "0j5qgrff6im5n9waflbi7w643q1p6mahyf2z35gb4vj9h5p76pfc"))
+        (base32 "0mhzvqs0im04y1cpcc1yma70hgdac1frf33h73m9z3356bfymmbr"))
        (modules '((guix build utils)))
        ;; zlib and openjpg should be under Libs, not Libs.private.  See:
        ;; https://code.google.com/p/tesseract-ocr/issues/detail?id=1436
@@ -228,7 +228,8 @@ the W3C's XML-based Scaleable Vector Graphic (SVG) format.")
           (lambda _
             (substitute* "prog/reg_wrapper.sh"
               ((" /bin/sh ")
-               (string-append " " (which "sh") " "))))))))
+               (string-append " " (which "sh") " "))
+              (("which gnuplot") (which "gnuplot"))))))))
     (home-page "http://www.leptonica.com/")
     (synopsis "Library and tools for image processing and analysis")
     (description