summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorAndreas Enge <andreas@enge.fr>2015-09-04 21:19:51 +0200
committerAndreas Enge <andreas@enge.fr>2015-09-04 21:30:00 +0200
commitced7cc92d7df106244d9df540f0f7b81744f1a8c (patch)
tree3967a0031301de96399ab66580cc9f054e224cf1 /gnu/packages/image.scm
parentf06441951c4178d8228ba3e3ca1841934f7a86b8 (diff)
downloadguix-ced7cc92d7df106244d9df540f0f7b81744f1a8c.tar.gz
gnu: vigra: Add support for OpenEXR.
* gnu/packages/image.scm (vigra)[inputs]: Add ilmbase and openexr.
  [arguments]: Augment #:configure-flags.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 84f03967a7..2e274953cd 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -31,6 +31,7 @@
   #:use-module (gnu packages fontutils)
   #:use-module (gnu packages ghostscript)
   #:use-module (gnu packages gl)
+  #:use-module (gnu packages graphics)
   #:use-module (gnu packages maths)
   #:use-module (gnu packages perl)
   #:use-module (gnu packages pkg-config)
@@ -525,9 +526,12 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
       ("fftw" ,fftw)
       ("fftwf" ,fftwf)
       ("hdf5" ,hdf5)
+      ("ilmbase" ,ilmbase) ; propagated by openexr, but needed explicitly
+                           ; to create a configure-flag
       ("libjpeg" ,libjpeg)
       ("libpng" ,libpng)
       ("libtiff" ,libtiff)
+      ("openexr" ,openexr)
       ("python" ,python-2) ; print syntax
       ("python2-numpy" ,python2-numpy)
       ("zlib" ,zlib)))
@@ -541,7 +545,15 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
         (list "-Wno-dev" ; suppress developer mode with lots of warnings
               (string-append "-DVIGRANUMPY_INSTALL_DIR="
                              (assoc-ref %outputs "out")
-                             "/lib/python2.7/site-packages"))))
+                             "/lib/python2.7/site-packages")
+              ;; OpenEXR is not enabled by default.
+              "-DWITH_OPENEXR=1"
+              ;; The header files of ilmbase are not found when included
+              ;; by the header files of openexr, and an explicit flag
+              ;; needs to be set.
+              (string-append "-DCMAKE_CXX_FLAGS=-I"
+                             (assoc-ref %build-inputs "ilmbase")
+                             "/include/OpenEXR"))))
    (synopsis "Computer vision library")
    (description
     "VIGRA stands for Vision with Generic Algorithms.  It is an image