summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2015-03-04 14:07:23 +0100
committerLudovic Courtès <ludo@gnu.org>2015-03-04 14:07:23 +0100
commit1289062522e3d08259740e59243c6cd0642a9916 (patch)
tree65857ae41001e3b33db621073cf1504de601dda1 /gnu/packages/image.scm
parentcb4d3d863b3fb44d97b3b568ff9e6cfe38f1f630 (diff)
parentda699774d4d839a45daa3ae3b9189331c490b315 (diff)
downloadguix-1289062522e3d08259740e59243c6cd0642a9916.tar.gz
Merge branch 'core-updates'.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm23
1 files changed, 9 insertions, 14 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index a71465dc12..46b0824c8d 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -385,20 +385,15 @@ supplies a generic doubly-linked list and some string functions.")
               "0q1gnjnxgphsh4l8i9rfly4bi8xsczsb9ryzbm8hf38lc3fk5bq3"))))
    (build-system gnu-build-system)
    (arguments
-    '(#:phases (alist-replace
-                'unpack
-                (lambda* (#:key source #:allow-other-keys)
-                  (and (zero? (system* "unzip" source))
-                       (chdir "FreeImage")))
-                (alist-delete
-                 'configure
-                 (alist-cons-before
-                  'build 'patch-makefile
-                  (lambda* (#:key outputs #:allow-other-keys)
-                    (substitute* "Makefile.gnu"
-                      (("/usr") (assoc-ref outputs "out"))
-                      (("-o root -g root") "")))
-                  %standard-phases)))
+    '(#:phases (alist-delete
+                'configure
+                (alist-cons-before
+                 'build 'patch-makefile
+                 (lambda* (#:key outputs #:allow-other-keys)
+                   (substitute* "Makefile.gnu"
+                     (("/usr") (assoc-ref outputs "out"))
+                     (("-o root -g root") "")))
+                 %standard-phases))
       #:make-flags '("CC=gcc")
       #:tests? #f)) ; no check target
    (native-inputs