summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2017-08-10 21:35:32 +0200
committerMarius Bakke <mbakke@fastmail.com>2017-08-10 22:23:31 +0200
commitc2f93e9c07c75e47078ab313ce9e0c90ff130eb1 (patch)
treebd6bb94f4e764ab40fda86258b26f437974024da /gnu/packages/image.scm
parent1a1558e88f1f119be9dca28dac0bf554bc6aa171 (diff)
downloadguix-c2f93e9c07c75e47078ab313ce9e0c90ff130eb1.tar.gz
gnu: openjpeg: Update to 2.2.0 [security fixes].
In addition to the patches we already had (which are not mentioned in the
ChangeLog, but verified by following their respective GitHub issues) this
release also fixes CVE-2016-9112, CVE-2016-5139, CVE-2016-5152, CVE-2016-5158,
CVE-2016-5159, CVE-2016-1626 and CVE-2016-1628.

See <https://github.com/uclouvain/openjpeg/blob/v2.2.0/CHANGELOG.md> for details.

* gnu/packages/patches/openjpeg-CVE-2016-9572-CVE-2016-9573.patch,
  gnu/packages/patches/openjpeg-CVE-2016-9850-CVE-2016-9851.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
* gnu/packages/image.scm (openjpeg): Update to 2.2.0.
[source](patches): Remove.
* gnu/packages/gstreamer.scm (gst-plugins-bad)[arguments]: Add phase to patch
hard-coded openjpeg-2.1 path.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm6
1 files changed, 2 insertions, 4 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 63e3fa5049..95a4c91b10 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -511,7 +511,7 @@ work.")
 (define-public openjpeg
   (package
     (name "openjpeg")
-    (version "2.1.2")
+    (version "2.2.0")
     (source
       (origin
         (method url-fetch)
@@ -521,9 +521,7 @@ work.")
         (file-name (string-append name "-" version ".tar.gz"))
         (sha256
          (base32
-          "19yz4g0c45sm8y1z01j9djsrl1mkz3pmw7fykc6hkvrqymp7prsc"))
-        (patches (search-patches "openjpeg-CVE-2016-9850-CVE-2016-9851.patch"
-                                 "openjpeg-CVE-2016-9572-CVE-2016-9573.patch"))))
+          "0yvfghxwfm3dcqr9krkw63pcd76hzkknc3fh7bh11s8qlvjvrpbg"))))
     (build-system cmake-build-system)
     (arguments
       ;; Trying to run `$ make check' results in a no rule fault.