summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-16 00:59:15 -0400
committerMark H Weaver <mhw@netris.org>2015-06-16 01:02:01 -0400
commit8e28d22c914122aa7bfb70847370d8ae0f070688 (patch)
tree14ffa1b7954a3f67c4057bc03ab35c993e98120f /gnu/packages/image.scm
parent7d02724b7bddb4d5e1cc93db99f737baa26840ca (diff)
downloadguix-8e28d22c914122aa7bfb70847370d8ae0f070688.tar.gz
gnu: libtiff: Add fixes for several CVEs.
* gnu/packages/patches/libtiff-CVE-2012-4564.patch,
  gnu/packages/patches/libtiff-CVE-2013-1960.patch,
  gnu/packages/patches/libtiff-CVE-2013-1961.patch,
  gnu/packages/patches/libtiff-CVE-2013-4231.patch,
  gnu/packages/patches/libtiff-CVE-2013-4232.patch,
  gnu/packages/patches/libtiff-CVE-2013-4243.patch,
  gnu/packages/patches/libtiff-CVE-2013-4244.patch,
  gnu/packages/patches/libtiff-CVE-2014-8127-pt1.patch,
  gnu/packages/patches/libtiff-CVE-2014-8127-pt2.patch,
  gnu/packages/patches/libtiff-CVE-2014-8127-pt3.patch,
  gnu/packages/patches/libtiff-CVE-2014-8127-pt4.patch,
  gnu/packages/patches/libtiff-CVE-2014-8128-pt1.patch,
  gnu/packages/patches/libtiff-CVE-2014-8128-pt2.patch,
  gnu/packages/patches/libtiff-CVE-2014-8128-pt3.patch,
  gnu/packages/patches/libtiff-CVE-2014-8128-pt4.patch,
  gnu/packages/patches/libtiff-CVE-2014-8128-pt5.patch,
  gnu/packages/patches/libtiff-CVE-2014-8129.patch,
  gnu/packages/patches/libtiff-CVE-2014-9330.patch,
  gnu/packages/patches/libtiff-CVE-2014-9655.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/image.scm (libtiff)[source]: Add patches.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm21
1 files changed, 20 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 89590cc5ad..a7483ba94a 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -112,7 +112,26 @@ image files in PBMPLUS PPM/PGM, GIF, BMP, and Targa file formats.")
             (uri (string-append "ftp://ftp.remotesensing.org/pub/libtiff/tiff-"
                    version ".tar.gz"))
             (sha256 (base32
-                     "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))))
+                     "0wj8d1iwk9vnpax2h29xqc2hwknxg3s0ay2d5pxkg59ihbifn6pa"))
+            (patches (map search-patch '("libtiff-CVE-2012-4564.patch"
+                                         "libtiff-CVE-2013-1960.patch"
+                                         "libtiff-CVE-2013-1961.patch"
+                                         "libtiff-CVE-2013-4231.patch"
+                                         "libtiff-CVE-2013-4232.patch"
+                                         "libtiff-CVE-2013-4244.patch"
+                                         "libtiff-CVE-2013-4243.patch"
+                                         "libtiff-CVE-2014-9330.patch"
+                                         "libtiff-CVE-2014-8127-pt1.patch"
+                                         "libtiff-CVE-2014-8127-pt2.patch"
+                                         "libtiff-CVE-2014-8127-pt3.patch"
+                                         "libtiff-CVE-2014-8127-pt4.patch"
+                                         "libtiff-CVE-2014-8128-pt1.patch"
+                                         "libtiff-CVE-2014-8128-pt2.patch"
+                                         "libtiff-CVE-2014-8128-pt3.patch"
+                                         "libtiff-CVE-2014-8129.patch"
+                                         "libtiff-CVE-2014-9655.patch"
+                                         "libtiff-CVE-2014-8128-pt4.patch"
+                                         "libtiff-CVE-2014-8128-pt5.patch")))))
    (build-system gnu-build-system)
    (inputs `(("zlib" ,zlib)
              ("libjpeg-8" ,libjpeg-8)))