summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-01-30 16:11:04 -0500
committerLeo Famulari <leo@famulari.name>2016-02-04 15:09:41 -0500
commit90bcecc56886ed8b3b55db01c1f0b015fc2fc9a1 (patch)
tree68ed124e373781025c7cea2fd762ac3dc67f8cdc /gnu/packages/image.scm
parente20f051ec45719631bdc5ea4fad9ab1787bb0c18 (diff)
downloadguix-90bcecc56886ed8b3b55db01c1f0b015fc2fc9a1.tar.gz
gnu: jasper: Add fixes for several security flaws.
* gnu/packages/patches/jasper-CVE-2007-2721.patch,
gnu/packages/patches/jasper-CVE-2008-3520.patch,
gnu/packages/patches/jasper-CVE-2011-4516-and-CVE-2011-4517.patch,
gnu/packages/patches/jasper-CVE-2014-8137.patch,
gnu/packages/patches/jasper-CVE-2014-8138.patch,
gnu/packages/patches/jasper-CVE-2014-8157.patch,
gnu/packages/patches/jasper-CVE-2014-8158.patch,
gnu/packages/patches/jasper-CVE-2014-9029.patch,
gnu/packages/patches/jasper-CVE-2016-1867.patch: New files.
* gnu-system.am (dist_patch_DATA): Add them.
* gnu/packages/image.scm (jasper)[source]: Add patches.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm14
1 files changed, 13 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index bf120f0184..f287054e41 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -6,6 +6,7 @@
 ;;; Copyright © 2015 Taylan Ulrich Bayırlı/Kammer <taylanbayirli@gmail.com>
 ;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
+;;; Copyright © 2016 Leo Famulari <leo@famulari.name>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -719,7 +720,18 @@ convert, manipulate, filter and display a wide variety of image formats.")
               (sha256
                (base32
                 "154l7zk7yh3v8l2l6zm5s2alvd2fzkp6c9i18iajfbna5af5m43b"))
-              (patches (list (search-patch "jasper-CVE-2008-3522.patch")))))
+              (patches
+                (list
+                  (search-patch "jasper-CVE-2007-2721.patch")
+                  (search-patch "jasper-CVE-2008-3520.patch")
+                  (search-patch "jasper-CVE-2008-3522.patch")
+                  (search-patch "jasper-CVE-2011-4516-and-CVE-2011-4517.patch")
+                  (search-patch "jasper-CVE-2014-8137.patch")
+                  (search-patch "jasper-CVE-2014-8138.patch")
+                  (search-patch "jasper-CVE-2014-8157.patch")
+                  (search-patch "jasper-CVE-2014-8158.patch")
+                  (search-patch "jasper-CVE-2014-9029.patch")
+                  (search-patch "jasper-CVE-2016-1867.patch")))))
     (build-system gnu-build-system)
     (native-inputs
      `(("unzip" ,unzip)))