summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMarius Bakke <mbakke@fastmail.com>2019-08-08 00:35:37 +0200
committerMarius Bakke <mbakke@fastmail.com>2019-08-08 00:35:37 +0200
commit8e7f97b9ffee10af3cf16958ebc0a7d410a19ca8 (patch)
treeb3836f9cea849fd8bfb61a77ba225a0054babe58 /gnu/packages/image.scm
parentfa228db78bc9dcb0e7da607dd8783224c76d7ef5 (diff)
parentba7ff983d613f735ee270f0b0e3c5dba5cbeda3c (diff)
downloadguix-8e7f97b9ffee10af3cf16958ebc0a7d410a19ca8.tar.gz
Merge branch 'master' into staging
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm13
1 files changed, 2 insertions, 11 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index c6b3eab4e8..5f3cf0ac2c 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -595,9 +595,6 @@ collection of tools for doing simple manipulations of TIFF images.")
     (arguments
      '(#:phases
        (modify-phases %standard-phases
-         (add-after 'unpack 'autogen
-           (lambda _
-             (invoke "sh" "autobuild")))
          (add-after 'unpack 'patch-reg-wrapper
            (lambda _
              (substitute* "prog/reg_wrapper.sh"
@@ -1108,14 +1105,14 @@ channels.")
 (define-public exiv2
   (package
     (name "exiv2")
-    (version "0.27.1")
+    (version "0.27.2")
     (source
      (origin
        (method url-fetch)
        (uri (string-append "https://www.exiv2.org/builds/exiv2-" version
                            "-Source.tar.gz"))
        (sha256
-        (base32 "109hbfk63dh14fz20ivq20gcclb9jj9jmh48w4lcn6zxh1ljh9gi"))))
+        (base32 "0gqminvj14xm3rgbnydbywf22608js80rp7nmxxk4497j5mzali6"))))
     (build-system cmake-build-system)
     (arguments '(#:tests? #f))          ; no test suite
     (propagated-inputs
@@ -1240,12 +1237,6 @@ ISO/IEC 15444-1).")
      `(("autoconf" ,autoconf)
        ("automake" ,automake)
        ("libtool" ,libtool)))
-    (arguments
-     '(#:phases
-       (modify-phases %standard-phases
-         (add-after 'unpack 'autogen
-           (lambda _
-             (invoke "sh" "autogen.sh"))))))
     (synopsis "Scaling, colorspace conversion, and dithering library")
     (description "Zimg implements the commonly required image processing basics
 of scaling, colorspace conversion, and depth conversion.  A simple API enables