summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2016-10-04 10:28:37 -0400
committerLeo Famulari <leo@famulari.name>2016-10-07 22:44:30 -0400
commitf803f775d244b4e3975ab42b9610d12b94f6e958 (patch)
tree32094c78256539a360912abdda003702ca852f68 /gnu/packages/image.scm
parent382aacc5a34d483da58e3395f33d572d631d6564 (diff)
downloadguix-f803f775d244b4e3975ab42b9610d12b94f6e958.tar.gz
gnu: vigra: Workaround rounding error in test suite on 32-bit CPUs.
* gnu/packages/image.scm (vigra)[arguments]: Pass '-ffloat-store' to
C_FLAGS and CXX_FLAGS.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm5
1 files changed, 4 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 4039c1a00b..b286089713 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -647,12 +647,15 @@ graphics image formats like PNG, BMP, JPEG, TIFF and others.")
                              "/lib/python2.7/site-packages")
               ;; OpenEXR is not enabled by default.
               "-DWITH_OPENEXR=1"
+              ;; Fix rounding error on 32-bit machines
+              "-DCMAKE_C_FLAGS=-ffloat-store"
               ;; The header files of ilmbase are not found when included
               ;; by the header files of openexr, and an explicit flag
               ;; needs to be set.
               (string-append "-DCMAKE_CXX_FLAGS=-I"
                              (assoc-ref %build-inputs "ilmbase")
-                             "/include/OpenEXR"))))
+                             "/include/OpenEXR"
+                             " -ffloat-store"))))
    (synopsis "Computer vision library")
    (description
     "VIGRA stands for Vision with Generic Algorithms.  It is an image