summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorLeo Famulari <leo@famulari.name>2017-05-27 11:31:52 -0400
committerLeo Famulari <leo@famulari.name>2017-05-28 14:34:43 -0400
commit22e6656d259838ae9014c1ed876caa9d819be6df (patch)
tree9cafcde5a5d845fa138a6f9d9b5d91458df56b41 /gnu/packages/image.scm
parent3cae15023f4b97554dcc6e914a5ddbc3a3c564d6 (diff)
downloadguix-22e6656d259838ae9014c1ed876caa9d819be6df.tar.gz
gnu: libtiff: Update replacement to 4.0.8 [security fixes].
See 'ChangeLog' in the source distribution for more information about
the bugs and security issues fixed in this release.

* gnu/packages/image.scm (libtiff)[replacement]: Replace with libtiff-4.0.8.
(libtiff/fixed): Replace with ...
(libtiff-4.0.8): New variable.
* gnu/packages/patches/libtiff-CVE-2017-7593.patch,
gnu/packages/patches/libtiff-CVE-2017-7594.patch,
gnu/packages/patches/libtiff-multiple-UBSAN-crashes.patch: Delete files.
* gnu/local.mk (dist_patch_DATA): Remove them.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm18
1 files changed, 9 insertions, 9 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index 86902d5680..fe9e457f34 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -335,7 +335,7 @@ extracting icontainer icon files.")
 (define-public libtiff
   (package
    (name "libtiff")
-   (replacement libtiff/fixed)
+   (replacement libtiff-4.0.8)
    (version "4.0.7")
    (source (origin
             (method url-fetch)
@@ -384,18 +384,18 @@ collection of tools for doing simple manipulations of TIFF images.")
                                   "See COPYRIGHT in the distribution."))
    (home-page "http://www.simplesystems.org/libtiff/")))
 
-(define libtiff/fixed
+(define libtiff-4.0.8
   (package
     (inherit libtiff)
+    (version "4.0.8")
     (source
      (origin
-       (inherit (package-source libtiff))
-       (patches
-        (append
-         (origin-patches (package-source libtiff))
-         (search-patches "libtiff-CVE-2017-7593.patch"
-                         "libtiff-CVE-2017-7594.patch"
-                         "libtiff-multiple-UBSAN-crashes.patch")))))))
+       (method url-fetch)
+       (uri (string-append "http://download.osgeo.org/libtiff/tiff-"
+                           version ".tar.gz"))
+       (sha256
+        (base32
+         "0419mh6kkhz5fkyl77gv0in8x4d2jpdpfs147y8mj86rrjlabmsr"))))))
 
 (define-public libwmf
   (package