summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-04-27 09:45:54 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-04-28 17:00:18 +0300
commit2f823fb493051df371f9637b782e6c46e13a8e10 (patch)
treec7ea9b74addbc9615b6cbe051896336098737a52 /gnu/packages/image.scm
parent587398d2a82e0b5966a6827d36a1f1d115181b11 (diff)
downloadguix-2f823fb493051df371f9637b782e6c46e13a8e10.tar.gz
gnu: libjpeg-turbo: Fix building on powerpc.
* gnu/packages/image.scm (libjpeg-turbo)[arguments]: Add configure-flags
specific to powerpc to fix building and cross-building.
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm9
1 files changed, 8 insertions, 1 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index c900bd0eb9..96e207e940 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -8,7 +8,7 @@
 ;;; Copyright © 2015 Amirouche Boubekki <amirouche@hypermove.net>
 ;;; Copyright © 2014, 2017 John Darrington <jmd@gnu.org>
 ;;; Copyright © 2016, 2017, 2018, 2020 Leo Famulari <leo@famulari.name>
-;;; Copyright © 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2016, 2017, 2018, 2019, 2020 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016, 2017, 2018, 2019, 2020 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;; Copyright © 2016 Eric Bavier <bavier@member.fsf.org>
 ;;; Copyright © 2016, 2017 Arun Isaac <arunisaac@systemreboot.net>
@@ -1532,6 +1532,10 @@ is hereby granted."))))
     (arguments
      `(#:configure-flags '("-DCMAKE_INSTALL_LIBDIR:PATH=lib"
                            "-DENABLE_STATIC=0"
+                           ;; djpeg-shared-3x2-float-prog-cmp fails on 32-bit PPC.
+                           ,@(if (string=? "powerpc-linux" (%current-system))
+                               `("-DFLOATTEST=NO")
+                               '())
                            ;; The build system probes for the current CPU, but
                            ;; that fails when cross-compiling.
                            ,@(let ((target (%current-target-system)))
@@ -1545,6 +1549,9 @@ is hereby granted."))))
                                      `("-DCMAKE_SYSTEM_PROCESSOR=x86"))
                                     ((string-prefix? "x86_64" target)
                                      `("-DCMAKE_SYSTEM_PROCESSOR=x86_64"))
+                                    ;; 32-bit and 64-bit
+                                    ((string-prefix? "powerpc" target)
+                                     `("-DCMAKE_SYSTEM_PROCESSOR=powerpc"))
                                     (else '()))
                                    '())))
        ,@(if (%current-target-system)