summary refs log tree commit diff
path: root/gnu/packages/image.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2015-06-18 01:32:37 -0400
committerMark H Weaver <mhw@netris.org>2015-06-18 01:32:37 -0400
commit2abf678682c42842c16e026c51d96b1fa86be88f (patch)
tree7bd59bd08dbaf00f23f37a91d1e7ae3d7a915843 /gnu/packages/image.scm
parent9ae1e920718e95577c12de890754b6a6a4ff70a1 (diff)
parentc362a40a5825faafc76b72f69fb6595fa29d3f60 (diff)
downloadguix-2abf678682c42842c16e026c51d96b1fa86be88f.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/image.scm')
-rw-r--r--gnu/packages/image.scm23
1 files changed, 23 insertions, 0 deletions
diff --git a/gnu/packages/image.scm b/gnu/packages/image.scm
index a7483ba94a..ad4acb787e 100644
--- a/gnu/packages/image.scm
+++ b/gnu/packages/image.scm
@@ -582,3 +582,26 @@ with lossy compression and typically provides 3x smaller file sizes compared
 to PNG when lossy compression is acceptable for the red/green/blue color
 channels.")
     (license license:bsd-3)))
+
+(define-public libmng
+  (package
+    (name "libmng")
+    (version "2.0.3")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "mirror://sourceforge/libmng/"
+                                  name "-" version ".tar.xz"))
+              (sha256
+               (base32
+                "1lvxnpds0vcf0lil6ia2036ghqlbl740c4d2sz0q5g6l93fjyija"))))
+    (build-system gnu-build-system)
+    (propagated-inputs
+     ;; These are all in the 'Libs.private' field of libmng.pc.
+     `(("lcms" ,lcms)
+       ("libjpeg" ,libjpeg)
+       ("zlib" ,zlib)))
+    (home-page "http://www.libmng.com/")
+    (synopsis "Library for handling MNG files")
+    (description
+     "Libmng is the MNG (Multiple-image Network Graphics) reference library.")
+    (license license:bsd-3)))