summary refs log tree commit diff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorMark H Weaver <mhw@netris.org>2016-04-23 02:49:15 -0400
committerMark H Weaver <mhw@netris.org>2016-04-23 05:05:18 -0400
commit0118c6ab62ac90136fe877ded67869c104440ffd (patch)
tree988b771b4c2a78f938ec268dc0ac6bc65ef87842 /gnu/packages/inkscape.scm
parente993fb849321b740c43d02c922101287426420fa (diff)
downloadguix-0118c6ab62ac90136fe877ded67869c104440ffd.tar.gz
gnu: inkscape: Fix build with glibmm-2.48.
* gnu/packages/patches/inkscape-drop-wait-for-targets.patch: New file.
* gnu/local.mk (dist_patch_DATA): Add it.
* gnu/packages/inkscape.scm (inkscape)[source]: Add patch.
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm7
1 files changed, 5 insertions, 2 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index b09e84ee08..16f83fc474 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -1,6 +1,6 @@
 ;;; GNU Guix --- Functional package management for GNU
 ;;; Copyright © 2014 John Darrington <jmd@gnu.org>
-;;; Copyright © 2014 Mark H Weaver <mhw@netris.org>
+;;; Copyright © 2014, 2016 Mark H Weaver <mhw@netris.org>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -52,7 +52,10 @@
                                   version ".tar.gz"))
               (sha256
                (base32
-                "086v01jy896dj86bq7plrf6si4p6gh6ga2v5417llgmminycz8rc"))))
+                "086v01jy896dj86bq7plrf6si4p6gh6ga2v5417llgmminycz8rc"))
+              (patch-flags '("-p0"))
+              (patches
+               (search-patches "inkscape-drop-wait-for-targets.patch"))))
     (build-system gnu-build-system)
     (inputs
      `(("aspell" ,aspell)