summary refs log tree commit diff
path: root/gnu/packages/inkscape.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2018-05-15 12:52:28 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2018-05-15 14:30:23 +0200
commit20f5c86c3e3226b04eaf2f7d29a1a0200f323033 (patch)
treee092aec9f84fe7d178edcfc1232ac9b7497d0287 /gnu/packages/inkscape.scm
parentcbd2e3d52dcf0e2f20de7be067a54361042ef01d (diff)
downloadguix-20f5c86c3e3226b04eaf2f7d29a1a0200f323033.tar.gz
gnu: inkscape: Disable "icon-theme.cache" generation.
* gnu/packages/inkscape.scm (inkscape)[arguments]<#:make-flags>: Delete.
<#:phases>[patch-icon-cache-generator]: Add phase.
Diffstat (limited to 'gnu/packages/inkscape.scm')
-rw-r--r--gnu/packages/inkscape.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/inkscape.scm b/gnu/packages/inkscape.scm
index ffd5f60b38..de9940df1c 100644
--- a/gnu/packages/inkscape.scm
+++ b/gnu/packages/inkscape.scm
@@ -80,8 +80,13 @@
     ;; FIXME: tests require gmock
     (arguments
      `(#:tests? #f
-       #:make-flags
-       '("gtk_update_icon_cache=true")))
+       #:phases
+       (modify-phases %standard-phases
+         (add-after 'unpack 'patch-icon-cache-generator
+           (lambda _
+             (substitute* "share/icons/application/CMakeLists.txt"
+              (("gtk-update-icon-cache") "true"))
+             #t)))))
     (home-page "https://inkscape.org/")
     (synopsis "Vector graphics editor")
     (description "Inkscape is a vector graphics editor.  What sets Inkscape