summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorTobias Geerinckx-Rice <me@tobias.gr>2019-09-10 15:26:38 +0200
committerTobias Geerinckx-Rice <me@tobias.gr>2019-09-10 21:37:19 +0200
commit07c0110eac24f2e1dc292e143d93f681244838a3 (patch)
tree313d628a5fe1bbd225935bce6fad39edd10bb175 /gnu/packages/irc.scm
parent4eb69bf0d33810886ee118f38989cef696e4c868 (diff)
downloadguix-07c0110eac24f2e1dc292e143d93f681244838a3.tar.gz
gnu: weechat: Update to 2.6.
* gnu/packages/irc.scm (weechat): Update to 2.6.
[source]: Remove obsolete patch.
[inputs]: Replace python-2 with python(@3).
[arguments]: Remove ‘wrap’ phase.
* gnu/packages/patches/weechat-python.patch: Delete file.
* gnu/local.mk (dist_patch_DATA): Remove it.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm20
1 files changed, 7 insertions, 13 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 622f1253d8..e3418c1fec 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -5,7 +5,7 @@
 ;;; Copyright © 2015, 2016, 2017, 2018, 2019 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 ng0 <ng0@n0.is>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
-;;; Copyright © 2017, 2018 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2017, 2018, 2019 Tobias Geerinckx-Rice <me@tobias.gr>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -166,15 +166,14 @@ SILC and ICB protocols via plugins.")
 (define-public weechat
   (package
     (name "weechat")
-    (version "2.5")
+    (version "2.6")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://weechat.org/files/src/weechat-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "09sc5lf7z70x3iw87q4zh8rbyngsw89pwnzs5jk195zzqdspgj2j"))
-              (patches (search-patches "weechat-python.patch"))))
+                "0j2iflnfvv31q2l9r67r8aj3ipggqfm2r2dpy7pvdpxgwwq337ps"))))
     (build-system cmake-build-system)
     (native-inputs
      `(("gettext" ,gettext-minimal)
@@ -187,9 +186,11 @@ SILC and ICB protocols via plugins.")
               ("aspell" ,aspell)
               ("curl" ,curl)
               ("gnutls" ,gnutls)
+
+              ;; Scripting language plug-ins.
               ("guile" ,guile-2.0)
               ("lua" ,lua-5.1)
-              ("python" ,python-2)
+              ("python" ,python)
               ("perl" ,perl)
               ("tcl" ,tcl)))
     (arguments
@@ -214,14 +215,7 @@ SILC and ICB protocols via plugins.")
              (substitute* "tests/scripts/test-scripts.cpp"
                ((".*\\{ \"(javascript|php|ruby)\", " all)
                 (string-append "// SKIP" all)))
-             #t))
-         (add-after 'install 'wrap
-           (lambda* (#:key inputs outputs #:allow-other-keys)
-             (let ((out (assoc-ref outputs "out"))
-                   (py2 (assoc-ref inputs "python")))
-               (wrap-program (string-append out "/bin/weechat")
-                 `("PATH" ":" prefix (,(string-append py2 "/bin"))))
-               #t))))))
+             #t)))))
     (synopsis "Extensible chat client")
     (description "WeeChat (Wee Enhanced Environment for Chat) is an
 @dfn{Internet Relay Chat} (IRC) client, which is designed to be light and fast.