summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2018-06-03 13:17:25 +0300
committerEfraim Flashner <efraim@flashner.co.il>2018-06-03 15:49:50 +0300
commit68ddfb2e8d43de248a64a9baf34ff7002053ede6 (patch)
tree2b8453771ee1a0ca66d33c4f010288f145da5458 /gnu/packages/irc.scm
parent4edc431b0f1a8893e950a3ee6c2fdebe9d5a6f7a (diff)
downloadguix-68ddfb2e8d43de248a64a9baf34ff7002053ede6.tar.gz
gnu: quassel: Fix building with Qt 5.11.
* gnu/packages/irc.scm (quassel)[sources]: Add patch. Return #t from
snippet.
* gnu/packages/patches/quassel-qt-5.11.patch: New file.
* gnu/local.mk (dist_patch_DATA): Register it.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm6
1 files changed, 4 insertions, 2 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 219e803089..993102f272 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -74,13 +74,15 @@
         (sha256
          (base32
           "1qkl3sb4ijx4k17m0c42j2p5bc4jymypwhmplm942rbrzm6mg50q"))
+        (patches (search-patches "quassel-qt-5.11.patch"))
         (modules '((guix build utils)))
         ;; We don't want to install the bundled scripts.
         (snippet
          '(begin
             (delete-file-recursively "data/scripts")
             (substitute* "data/CMakeLists.txt"
-              (("NOT WIN32") "WIN32"))))))
+              (("NOT WIN32") "WIN32"))
+            #t))))
     (build-system cmake-build-system)
     (arguments
       ;; The three binaries are not mutually exlusive, and are all built
@@ -91,7 +93,7 @@
                            "-DUSE_QT5=ON" ; default is qt4
                            "-DWITH_KDE=OFF" ; no to kde integration ...
                            "-DWITH_OXYGEN=ON" ; therefore we install bundled icons
-                           "-DWITH_WEBKIT=OFF") ; qtwebkit isn't packaged
+                           "-DWITH_WEBKIT=OFF") ; we don't depend on qtwebkit
        #:tests? #f)) ; no test target
     (native-inputs
      `(("extra-cmake-modules" ,extra-cmake-modules)