summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2022-07-18 14:17:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2022-07-18 14:17:52 +0300
commitf44dff89ad31a275630f0cb10a4addaea20d71d8 (patch)
tree8932c88825a2c75bce7f7ee9b5b78ffc459a59d7 /gnu/packages/irc.scm
parent548b7b182fcaea5acb5601be718899d92a0d10af (diff)
downloadguix-f44dff89ad31a275630f0cb10a4addaea20d71d8.tar.gz
gnu: weechat: Update to 3.6.
* gnu/packages/irc.scm (weechat): Update to 3.6.
[arguments]: Adjust instances of architecture specific code.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm13
1 files changed, 5 insertions, 8 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 8c484efb2d..5fc69cab3b 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -194,21 +194,20 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
 (define-public weechat
   (package
     (name "weechat")
-    (version "3.5")
+    (version "3.6")
     (source (origin
               (method url-fetch)
               (uri (string-append "https://weechat.org/files/src/weechat-"
                                   version ".tar.xz"))
               (sha256
                (base32
-                "030p1264rrbr5sbyww85xq0cm5zzdmnpz89y9z90ppcfxi64x47a"))))
+                "1ppj676gwh67krq92xnfkmh3qnwbz8d51djsscxw013x7cdxg1cx"))))
     (build-system cmake-build-system)
     (outputs '("out" "doc"))
     (native-inputs
      `(("gettext-minimal" ,gettext-minimal)
        ("pkg-config" ,pkg-config)
-       ,@(if (or (target-x86-64?)
-                 (target-x86-32?))
+       ,@(if (target-x86?)
            `(("ruby-asciidoctor" ,ruby-asciidoctor))
            '())
        ;; For tests.
@@ -231,16 +230,14 @@ Conferencing} and @acronym{ICB, Internet Citizen's Band}.")
     (arguments
      `(#:configure-flags
        (list "-DENABLE_PHP=OFF"
-             ,@(if (or (target-x86-64?)
-                       (target-x86-32?))
+             ,@(if (target-x86?)
                  '("-DENABLE_MAN=ON"
                    "-DENABLE_DOC=ON")
                 '())
              "-DENABLE_TESTS=ON")       ; ‘make test’ fails otherwise
        #:phases
        (modify-phases %standard-phases
-         ,@(if (or (target-x86-64?)
-                   (target-x86-32?))
+         ,@(if (target-x86?)
              '((add-after 'install 'move-doc
                  (lambda* (#:key outputs #:allow-other-keys)
                    (let* ((out (assoc-ref outputs "out"))