summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2020-07-17 12:32:52 +0300
committerEfraim Flashner <efraim@flashner.co.il>2020-07-17 12:36:10 +0300
commit0e1428ac5dc3a7f1aa68988dd88885009e9706a6 (patch)
treececc7a6df1e3f42c2a0f89ba7c334c8578d0251d /gnu/packages/irc.scm
parent22b3a95f6eb375c9ca89af9eeee8ec9903abd557 (diff)
downloadguix-0e1428ac5dc3a7f1aa68988dd88885009e9706a6.tar.gz
gnu: quassel: Fix calling inxi script.
* gnu/packages/irc.scm (quassel)[source]: Only remove bundled inxi script.
[arguments]: Adjust 'patch-inxi-reference phase to symlink packaged inxi
to where quassel expects it to be.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm9
1 files changed, 3 insertions, 6 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 81e4205acf..5abd54b49a 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -80,12 +80,10 @@
           "0mg8jydc70vlylppzich26q4s40kr78r3ysfyjwisfvlg2byxvs8"))
         (patches (search-patches "quassel-qt-514-compat.patch"))
         (modules '((guix build utils)))
-        ;; We don't want to install the bundled scripts.
+        ;; We don't want to install the bundled inxi script.
         (snippet
          '(begin
-            (delete-file-recursively "data/scripts")
-            (substitute* "data/CMakeLists.txt"
-              (("NOT WIN32") "WIN32"))
+            (delete-file "data/scripts/inxi")
             #t))))
     (build-system cmake-build-system)
     (arguments
@@ -103,8 +101,7 @@
          (add-after 'unpack 'patch-inxi-reference
            (lambda* (#:key inputs #:allow-other-keys)
              (let ((inxi (string-append (assoc-ref inputs "inxi") "/bin/inxi")))
-               (substitute* "src/common/aliasmanager.cpp"
-                 ((" inxi ") (string-append " " inxi " ")))
+               (symlink inxi "data/scripts/inxi")
                #t))))
        #:tests? #f)) ; no test target
     (native-inputs