summary refs log tree commit diff
path: root/gnu/packages/irc.scm
diff options
context:
space:
mode:
authorEfraim Flashner <efraim@flashner.co.il>2017-09-04 11:18:56 +0300
committerEfraim Flashner <efraim@flashner.co.il>2017-09-04 11:21:42 +0300
commit709a3bb7b8504093aa1c6bef7fd7c5cb07ca5b13 (patch)
treefa7d6306bfe8c11c884c5e8cdd6e39f02c5d5782 /gnu/packages/irc.scm
parentd10092b849153dc27cfed0a9601fde6c7bdec918 (diff)
downloadguix-709a3bb7b8504093aa1c6bef7fd7c5cb07ca5b13.tar.gz
gnu: weechat: Change to cmake-build-system.
* gnu/packages/irc.scm (weechat)[build-system]: Switch to
cmake-build-system.
[arguments]: Remove configure-flags, disable tets, remove
'autogen phase.
[inputs]: Remove diffutils, libltdl, openssl, cyrus-sasl. Move gettext ...
[native-inputs]: ... to here. Remove autoconf, file, autogen, automake,
libtool.
Diffstat (limited to 'gnu/packages/irc.scm')
-rw-r--r--gnu/packages/irc.scm24
1 files changed, 5 insertions, 19 deletions
diff --git a/gnu/packages/irc.scm b/gnu/packages/irc.scm
index 2e8d3d4573..cdbdc44e68 100644
--- a/gnu/packages/irc.scm
+++ b/gnu/packages/irc.scm
@@ -2,7 +2,7 @@
 ;;; Copyright © 2013 Cyril Roelandt <tipecaml@gmail.com>
 ;;; Copyright © 2014 Kevin Lemonnier <lemonnierk@ulrar.net>
 ;;; Copyright © 2015 Ludovic Courtès <ludo@gnu.org>
-;;; Copyright © 2015, 2016 Efraim Flashner <efraim@flashner.co.il>
+;;; Copyright © 2015, 2016, 2017 Efraim Flashner <efraim@flashner.co.il>
 ;;; Copyright © 2016 ng0 <ng0@libertad.pw>
 ;;; Copyright © 2017 Marius Bakke <mbakke@fastmail.com>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
@@ -152,37 +152,23 @@ SILC and ICB protocols via plugins.")
                (base32
                 "1zvxz98krq98y7jh3yrjbardg3yxp6y2031rvb7rp5ssk8lyp1fc"))
               (patches (search-patches "weechat-python.patch"))))
-    (build-system gnu-build-system)
-    (native-inputs `(("autoconf" ,autoconf)
-                     ("pkg-config" ,pkg-config)
-                     ("file" ,file)
-                     ("autogen" ,autogen)
-                     ("automake" ,automake)
-                     ("libtool" ,libtool)))
+    (build-system cmake-build-system)
+    (native-inputs `(("gettext" ,gettext-minimal)
+                     ("pkg-config" ,pkg-config)))
     (inputs `(("ncurses" ,ncurses)
-              ("diffutils" ,diffutils)
-              ("gettext" ,gettext-minimal)
-              ("libltdl" ,libltdl)
               ("libgcrypt" ,libgcrypt "out")
               ("zlib" ,zlib)
               ("aspell" ,aspell)
               ("curl" ,curl)
               ("gnutls" ,gnutls)
               ("guile" ,guile-2.0)
-              ("openssl" ,openssl)
-              ("cyrus-sasl" ,cyrus-sasl)
               ("lua" ,lua-5.1)
               ("python" ,python-2)
               ("perl" ,perl)
               ("tcl" ,tcl)))
     (arguments
-     `(#:configure-flags (list (string-append
-                                "--with-tclconfig="
-                                (assoc-ref %build-inputs "tcl") "/lib"))
+     `(#:tests? #f ; tests require cpputime
        #:phases (modify-phases %standard-phases
-                  (add-after 'unpack 'autogen
-                    (lambda _
-                      (zero? (system* "sh" "autogen.sh"))))
                   (add-after 'install 'wrap
                     (lambda* (#:key inputs outputs #:allow-other-keys)
                       (let ((out (assoc-ref outputs "out"))