summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorRicardo Wurmus <rekado@elephly.net>2021-12-18 17:25:28 +0100
committerRicardo Wurmus <rekado@elephly.net>2021-12-23 20:27:46 +0100
commit7bd34b0b19a43d217e5ed6f34e3bca9fa8c6be80 (patch)
treebabbd9b400304fbae0bff8785af3faf045709746 /gnu/packages/java.scm
parent993e26cbe1b0ced403d71bc81c088e9d55815499 (diff)
downloadguix-7bd34b0b19a43d217e5ed6f34e3bca9fa8c6be80.tar.gz
gnu: ant-bootstrap: Bind OUTPUTS in build phase.
* gnu/packages/java.scm (ant-bootstrap)[arguments]: Bind OUTPUTS to remove
reference to global %OUTPUTS.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm4
1 files changed, 2 insertions, 2 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 94567ba5bc..0835383f5d 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -359,7 +359,7 @@ JNI.")
              (setenv "JAVAC" (search-input-file inputs "/bin/jikes"))
              (setenv "CLASSPATH" (search-input-file inputs "/lib/rt.jar"))))
          (replace 'build
-           (lambda* (#:key inputs #:allow-other-keys)
+           (lambda* (#:key inputs outputs #:allow-other-keys)
              ;; Ant complains if this file doesn't exist.
              (setenv "HOME" "/tmp")
              (with-output-to-file "/tmp/.ant.properties"
@@ -386,7 +386,7 @@ JNI.")
                (("depends=\"jars,test-jar\"") "depends=\"jars\""))
              (invoke "bash" "bootstrap.sh"
                      (string-append "-Ddist.dir="
-                                    (assoc-ref %outputs "out")))))
+                                    (assoc-ref outputs "out")))))
          (add-after 'build 'strip-jar-timestamps ;based on ant-build-system
            (lambda* (#:key outputs #:allow-other-keys)
              (define (repack-archive jar)