summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-06 10:42:57 +0100
committerHartmut Goebel <h.goebel@crazy-compilers.com>2016-11-06 10:42:57 +0100
commit006728966a7bb4c6fd0d8d4b05b71fea47645765 (patch)
tree797087fb1fdc752afee4e0b5c38e3209243aace3 /gnu/packages/java.scm
parent937bc2d1370b8581d37c49b5281a7b8ebdfe8312 (diff)
downloadguix-006728966a7bb4c6fd0d8d4b05b71fea47645765.tar.gz
gnu: java-hamcrest-core: Update upstream location.
The checksum changed since the new location's archive contains no
jar-files (except those of external libraries) and line endings are
different.

* gnu/packages/java.scm (java-hamcrest-core)[source]: Update source
  uri and checksum. [snippet]: Remove directory "lib" completely.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm11
1 files changed, 6 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 36c10d0fd0..f6960dab0a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1180,16 +1180,17 @@ an Ant task that extends the built-in @code{jar} task.")
     (version "1.3")
     (source (origin
               (method url-fetch)
-              (uri (string-append "https://hamcrest.googlecode.com/files/"
-                                  "hamcrest-" version ".tgz"))
+              (uri (string-append "https://github.com/hamcrest/JavaHamcrest/"
+                                  "archive/hamcrest-java-" version ".tar.gz"))
+              (file-name (string-append name "-" version ".tar.gz"))
               (sha256
                (base32
-                "1hi0jv0zrgsf4l25aizxrgvxpsrmdklsmvw0jzwz7zv9s108whn6"))
+                "11g0s105fmwzijbv08lx8jlb521yravjmxnpgdx08fvg1kjivhva"))
               (modules '((guix build utils)))
               (snippet
                '(begin
-                  ;; Delete bundled jar archives.
-                  (for-each delete-file (find-files "." "\\.jar$"))
+                  ;; Delete bundled thirds-party jar archives.
+                  (delete-file-recursively "lib")
                   #t))))
     (build-system ant-build-system)
     (arguments