summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2020-04-05 21:31:30 +0200
committerJulien Lepiller <julien@lepiller.eu>2020-07-17 04:10:46 +0200
commite0ee843f77b495cc2d8f4a402358b4628a687bfa (patch)
treeba8099f93c8f029b6268049949a6d79da923056b /gnu/packages/java.scm
parent29428e10b832e99af70eafdb381a45bd701b3397 (diff)
downloadguix-e0ee843f77b495cc2d8f4a402358b4628a687bfa.tar.gz
gnu: java-jarjar: unbundle maven-plugin-api.
* gnu/packages/java.scm (java-jarjar): Unbundle maven-plugin-api.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm15
1 files changed, 11 insertions, 4 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index c74afa726b..70d8b619df 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -3544,10 +3544,10 @@ documentation tools.")
               (snippet
                '(begin
                   ;; Delete bundled thirds-party jar archives.
-                  ;; TODO: unbundle maven-plugin-api.
-                  (delete-file "lib/asm-4.0.jar")
-                  (delete-file "lib/asm-commons-4.0.jar")
-                  (delete-file "lib/junit-4.8.1.jar")
+                  (delete-file-recursively "lib")
+                  (delete-file "src/test/enumtest.jar")
+                  ;; the CLASSPATH needs this directory, create an empty one
+                  (mkdir-p "lib")
                   #t))))
     (build-system ant-build-system)
     (arguments
@@ -3576,6 +3576,13 @@ documentation tools.")
                                "<include name=\"org/objectweb/asm/"
                                "commons/SignatureRemapper.class\"/>")))
              #t))
+         (add-before 'build 'remove-maven-dependency
+           (lambda _
+             ;; We do not need to build jarjar as a maven plugin just yet, so
+             ;; remove this file.  Maven requires jarjar (but not that plugin),
+             ;; so removing it improves the bootstrap.
+             (delete-file "src/main/com/tonicsystems/jarjar/JarJarMojo.java")
+             #t))
          (replace 'install
            (lambda* (#:key outputs #:allow-other-keys)
              (let ((target (string-append (assoc-ref outputs "out")