summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorDanny Milosavljevic <dannym@scratchpost.org>2023-09-21 17:33:24 +0200
committerDanny Milosavljevic <dannym@scratchpost.org>2023-09-21 20:36:13 +0200
commit5ef168f91c37635835e30bf049e6516d673e97c7 (patch)
tree5aa7e0e437795169f088353f3c4a2663a99b8663 /gnu/packages/java.scm
parentec8c5d027f87bb39ce3fd03c40a13d7b316d9dac (diff)
downloadguix-5ef168f91c37635835e30bf049e6516d673e97c7.tar.gz
gnu: Add jbr@21-b240.22.
* gnu/packages/java.scm (jbr21): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm39
1 files changed, 39 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 0307b09acf..502bd30247 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -61,6 +61,7 @@
   #:use-module (gnu packages compression)
   #:use-module (gnu packages elf)
   #:use-module (gnu packages fontutils)
+  #:use-module (gnu packages freedesktop) ; wayland
   #:use-module (gnu packages gawk)
   #:use-module (gnu packages gcc)
   #:use-module (gnu packages gettext)
@@ -1641,6 +1642,44 @@ OpenJDK.")
     (home-page "https://www.jetbrains.com/")
     (license license:gpl2+)))
 
+(define-public jbr21
+  (package
+    (inherit openjdk21)
+    (name "jbr")
+    (version "21-b240.22")
+    (source (origin
+              (method git-fetch)
+              (uri (git-reference
+                     (url "https://github.com/JetBrains/JetBrainsRuntime.git")
+                     (commit (string-append "jb" version))))
+              (file-name (string-append name "-" version "-checkout"))
+              (sha256
+               (base32
+                "1sx48mm5vap4ab1qr6hy25wlgxljmhvpvrqiqiq692izr8dh7j4c"))
+              (patches (search-patches "openjdk-21-fix-rpath.patch"
+                                       "jbr-17-xcursor-no-dynamic.patch"))))
+    (inputs
+     `(("wayland" ,wayland)
+       ,@(package-inputs openjdk21)))
+    (arguments
+     (substitute-keyword-arguments (package-arguments openjdk21)
+       ((#:configure-flags configure-flags)
+        #~(append #$configure-flags
+                  (list "--with-jvm-features=shenandoahgc"
+                        "--enable-cds=yes"
+                        "--with-vendor-name=JetBrains s.r.o"
+                        "--with-vendor-url=https://www.jetbrains.com/"
+                        "--with-vendor-bug-url=https://youtrack.jetbrains.com/issues/JBR")))))
+    (synopsis "JetBrains Java Runtime")
+    (description "This package provides a Java runtime environment for
+and Java development kit.  It supports enhanced class redefinition (DCEVM),
+includes a number of improvements in font rendering, keyboards support,
+windowing/focus subsystems, HiDPI, accessibility, and performance,
+provides better desktop integration and bugfixes not yet present in
+OpenJDK.")
+    (home-page "https://www.jetbrains.com/")
+    (license license:gpl2+)))
+
 
 (define-public ant/java8
   (package