summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2018-07-02 11:02:11 +0200
committerGábor Boskovits <boskovits@gmail.com>2018-07-02 14:41:27 +0200
commit1cdff8cdb7b4822bd16fe713bc0b138a01a546aa (patch)
treed51b5b8784c642e3322d237ff6bf8631f43a2624 /gnu/packages/java.scm
parent79f9b054dff6fc76073b1b040db9d80881e55f42 (diff)
downloadguix-1cdff8cdb7b4822bd16fe713bc0b138a01a546aa.tar.gz
gnu: icedtea: Work around gcc segfault.
* gnu/packages/java.scm (icedtea-6)[arguments]: Modify phases to extract
hostspot, as after the patching it becomes an archive.
[native-inputs]: add patch to hotspot-src.
* gnu/packages/patches/icedtea-6-hotspot-gcc-segfault-workaround.patch:
New file.
* gnu/local.mk (dist_patch_DATA): Add it.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm9
1 files changed, 7 insertions, 2 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index f04a3828e6..1b4cc4d3b0 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -684,8 +684,11 @@ machine.")))
                                    (assoc-ref inputs
                                               (string-append part "-src"))
                                    part))
-                                '("jdk" "hotspot" "corba"
+                                '("jdk" "corba"
                                   "langtools" "jaxp" "jaxws")))
+                    (with-directory-excursion "openjdk"
+                      (invoke "tar" "xvf" (assoc-ref inputs "hotspot-src"))
+                      (rename-file "hg-checkout" "hotspot"))
                     (substitute* "Makefile.in"
                       (("echo \"ERROR: No up-to-date OpenJDK zip available\"; exit -1;")
                        "echo \"trust me\";")
@@ -905,7 +908,9 @@ machine.")))
                  (changeset "jdk6-b41")))
            (sha256
             (base32
-             "07lc1z4k5dj9nrc1wvwmpvxr3xgxrdkdh53xb95skk5ij49yagfd"))))
+             "07lc1z4k5dj9nrc1wvwmpvxr3xgxrdkdh53xb95skk5ij49yagfd"))
+           (patches
+            (search-patches "icedtea-6-hotspot-gcc-segfault-workaround.patch"))))
        ("corba-src"
         ,(origin
            (method hg-fetch)