summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorGábor Boskovits <boskovits@gmail.com>2018-01-07 22:23:56 +0100
committerChris Marusich <cmmarusich@gmail.com>2018-01-20 13:03:37 -0800
commitd0e9ded713e06790aad4992de7c26d075d18b86d (patch)
treef0a99659f32f058fee176a7a8c4d13e5db0764da /gnu/packages/java.scm
parent8329cb53d3dbbe80e5513fcfce06de8dbdd56867 (diff)
downloadguix-d0e9ded713e06790aad4992de7c26d075d18b86d.tar.gz
gnu: java-asm: Update to 6.0.
* gnu/packages/java.scm (java-asm): Update to 6.0.
[propagated-inputs]: Add java-aqute-bndlib.
[arguments]: Adjust #:make-flags accordingly.

Co-authored-by: Chris Marusich <cmmarusich@gmail.com>
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm20
1 files changed, 15 insertions, 5 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index d8c2c325bc..2724f0f20a 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -7,6 +7,8 @@
 ;;; Copyright © 2017 Thomas Danckaert <post@thomasdanckaert.be>
 ;;; Copyright © 2016, 2017, 2018 Alex Vong <alexvong1995@gmail.com>
 ;;; Copyright © 2017 Tobias Geerinckx-Rice <me@tobias.gr>
+;;; Copyright © 2018 Gábor Boskovits <boskovits@gmail.com>
+;;; Copyright © 2018 Chris Marusich <cmmarusich@gmail.com>
 ;;;
 ;;; This file is part of GNU Guix.
 ;;;
@@ -2660,23 +2662,31 @@ archives (jar).")
 (define-public java-asm
   (package
     (name "java-asm")
-    (version "5.2")
+    (version "6.0")
     (source (origin
               (method url-fetch)
               (uri (string-append "http://download.forge.ow2.org/asm/"
                                   "asm-" version ".tar.gz"))
               (sha256
                (base32
-                "0kxvmv5275rnjl7jv0442k3wjnq03ngkb7sghs78avf45pzm4qgr"))))
+                "115l5pqblirdkmzi32dxx7gbcm4jy0s14y5wircr6h8jdr9aix00"))))
     (build-system ant-build-system)
+    (propagated-inputs
+     `(("java-aqute-bndlib" ,java-aqute-bndlib)))
     (arguments
      `(#:build-target "compile"
        ;; The tests require an old version of Janino, which no longer compiles
        ;; with the JDK7.
        #:tests? #f
-       ;; We don't need these extra ant tasks, but the build system asks us to
-       ;; provide a path anyway.
-       #:make-flags (list (string-append "-Dobjectweb.ant.tasks.path=foo"))
+       #:make-flags
+       (list
+        ;; We don't need these extra ant tasks, but the build system asks us to
+        ;; provide a path anyway.
+        "-Dobjectweb.ant.tasks.path=dummy-path"
+        ;; The java-aqute.bndlib JAR file will be put onto the classpath and
+        ;; used during the build automatically by ant-build-system, but
+        ;; java-asm's build.xml fails unless we provide something here.
+        "-Dbiz.aQute.bnd.path=dummy-path")
        #:phases
        (modify-phases %standard-phases
          (add-before 'install 'build-jars