summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorJulien Lepiller <julien@lepiller.eu>2018-02-10 18:42:58 +0100
committerJulien Lepiller <julien@lepiller.eu>2018-02-10 19:04:36 +0100
commite06bf42811d57f8a391673b40e0ec7933958757a (patch)
tree26f8f6000094ead40255e7f30533fa7959315bd6 /gnu/packages/java.scm
parent5ee7b02f563e3f50fc69d1a0ae0e7f3f940a2dba (diff)
downloadguix-e06bf42811d57f8a391673b40e0ec7933958757a.tar.gz
gnu: Add java-jline.
* gnu/packages/java.scm (java-jline): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm31
1 files changed, 31 insertions, 0 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 3088803fd3..1f1b238a28 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -8255,3 +8255,34 @@ specification.  It also handles namespaces according to the XML Namespaces 1.1
 Candidate Recommendation, and will correctly serialize XML 1.1 documents if
 the DOM level 3 load/save API's are in use.")
     (license license:asl2.0)))
+
+(define-public java-jline
+  (package
+    (name "java-jline")
+    (version "1.0")
+    (source (origin
+              (method url-fetch)
+              (uri (string-append "https://github.com/jline/jline1/archive/jline-"
+                                  version ".tar.gz"))
+              (sha256
+               (base32
+                "0bi3p6vrh7a6v0fbpb6rx9plpmx5zk3lr352xzdbz2jcxg499wir"))))
+    (build-system ant-build-system)
+    (arguments
+     `(#:jar-name "jline.jar"
+       #:source-dir "src/main/java"
+       #:test-dir "src/test"
+       #:phases
+       (modify-phases %standard-phases
+         (add-before 'build 'copy-resources
+           (lambda _
+             (copy-recursively "src/main/resources" "build/classes")
+             #t)))))
+    (native-inputs
+     `(("java-junit" ,java-junit)))
+    (home-page "https://jline.github.io")
+    (synopsis "Console input handling library")
+    (description "JLine is a Java library for handling console input.  It is
+similar in functionality to BSD editline and GNU readline but with additional
+features that bring it on par with the Z shell line editor.")
+    (license license:bsd-3)))