summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorLudovic Courtès <ludo@gnu.org>2019-10-07 17:06:13 +0200
committerLudovic Courtès <ludo@gnu.org>2019-10-07 17:06:13 +0200
commit4d8d2fbaf3025337f7feff627282447db82a99d5 (patch)
treea524009a7ef257b894a6de73fd1e9b340fc735fd /gnu/packages/java.scm
parente08902d3cbb307e1523485becbbdaf9aed56ac4a (diff)
parentfa984fa678f98ddc72cc89c6f6dc50ba4aff2487 (diff)
downloadguix-4d8d2fbaf3025337f7feff627282447db82a99d5.tar.gz
Merge branch 'master' into core-updates
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm15
1 files changed, 12 insertions, 3 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 495e6bbd3a..d9ea5526b8 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -1406,12 +1406,17 @@ bootstrapping purposes.")
            (add-after 'install 'install-libjvm
              (lambda* (#:key inputs outputs #:allow-other-keys)
                (let* ((lib-path (string-append (assoc-ref outputs "out")
-                                               "/lib/"
+                                               ;; See 'INSTALL_ARCH_DIR' in
+                                               ;; 'configure'.
                                                ,(match (%current-system)
                                                   ("i686-linux"
-                                                   "i386")
+                                                   "/lib/i386")
                                                   ("x86_64-linux"
-                                                   "amd64")))))
+                                                   "/lib/amd64")
+                                                  ("armhf-linux"
+                                                   "/lib/arm")
+                                                  ("aarch64-linux"
+                                                   "/lib/aarch64")))))
                  (symlink (string-append lib-path "/server/libjvm.so")
                           (string-append lib-path "/libjvm.so")))
                #t))
@@ -1559,6 +1564,10 @@ bootstrapping purposes.")
       (description
        "This package provides the Java development kit OpenJDK built with the
 IcedTea build harness.")
+
+      ;; 'configure' lists "mips" and "mipsel", but not "mips64el'.
+      (supported-systems (delete "mips64el-linux" %supported-systems))
+
       ;; IcedTea is released under the GPL2 + Classpath exception, which is the
       ;; same license as both GNU Classpath and OpenJDK.
       (license license:gpl2+))))