summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorSimon South <simon@simonsouth.net>2020-06-15 11:22:52 -0400
committerEfraim Flashner <efraim@flashner.co.il>2020-10-28 10:33:50 +0200
commitdc3c27554be14c0fbf3c4668d1eb1a3b25d5ac00 (patch)
tree37fe8ef38f1aa623fe587fb3274f8f14934a55f0 /gnu/packages/java.scm
parent31ccd55176a37a2667ddf8e54e4943fa85fee734 (diff)
downloadguix-dc3c27554be14c0fbf3c4668d1eb1a3b25d5ac00.tar.gz
gnu: icedtea-6: Remove obsolete, architecture-dependent patch.
* gnu/packages/java.scm (icedtea-6)[arguments]<#:phases>: Remove special
handling of "hotspot-src" input during "unpack" phase.
[native-inputs]: Remove patch to "hotspot-src".
* gnu/packages/patches/icedtea-6-hotspot-gcc-segfault-workaround.patch: Delete
file.
* gnu/local.mk (dist_patch_DATA): Remove it.

Signed-off-by: Efraim Flashner <efraim@flashner.co.il>
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm9
1 files changed, 2 insertions, 7 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index 1d6d957eff..8432fa3452 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -889,11 +889,8 @@ machine.")))
                             (assoc-ref inputs
                                        (string-append part "-src"))
                             part))
-                         '("jdk" "corba"
+                         '("jdk" "hotspot" "corba"
                            "langtools" "jaxp" "jaxws")))
-             (with-directory-excursion "openjdk"
-               (invoke "tar" "xvf" (assoc-ref inputs "hotspot-src"))
-               (rename-file "hg-checkout" "hotspot"))
              (substitute* "patches/freetypeversion.patch"
                (("REQUIRED_FREETYPE_VERSION = 2.2.1")
                 "REQUIRED_FREETYPE_VERSION = 2.10.1"))
@@ -1119,9 +1116,7 @@ machine.")))
                  (changeset "jdk6-b41")))
            (sha256
             (base32
-             "07lc1z4k5dj9nrc1wvwmpvxr3xgxrdkdh53xb95skk5ij49yagfd"))
-           (patches
-            (search-patches "icedtea-6-hotspot-gcc-segfault-workaround.patch"))))
+             "07lc1z4k5dj9nrc1wvwmpvxr3xgxrdkdh53xb95skk5ij49yagfd"))))
        ("corba-src"
         ,(origin
            (method hg-fetch)