summary refs log tree commit diff
path: root/gnu/packages/java.scm
diff options
context:
space:
mode:
authorMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 09:30:28 -0400
committerMaxim Cournoyer <maxim.cournoyer@gmail.com>2022-09-27 10:05:54 -0400
commitfb6173b7c0aab02efdf15bfc9a00791f77a8b04f (patch)
treeb6b14fffdb119f2b0cee799380f1255eb33f469a /gnu/packages/java.scm
parentb2aa42435bf394b147d7df3471d20c244064997d (diff)
downloadguix-fb6173b7c0aab02efdf15bfc9a00791f77a8b04f.tar.gz
gnu: openjdk: Update to 18.
* gnu/packages/java.scm (openjdk): Update to 18.
(openjdk18): New variable.
Diffstat (limited to 'gnu/packages/java.scm')
-rw-r--r--gnu/packages/java.scm37
1 files changed, 4 insertions, 33 deletions
diff --git a/gnu/packages/java.scm b/gnu/packages/java.scm
index bc5009ead7..3ab324cce9 100644
--- a/gnu/packages/java.scm
+++ b/gnu/packages/java.scm
@@ -2167,41 +2167,12 @@ blacklisted.certs.pem"
                (substitute* "make/data/blockedcertsconverter/blocked.certs.pem"
                  (("^#!.*") "#! java BlockedCertsConverter SHA-256\n"))))))))))
 
-;; (define-public openjdk18
-;;   (package
-;;     (inherit openjdk17)
-;;     (name "openjdk")
-;;     (version "18")
-;;     (source (origin
-;;               (method git-fetch)
-;;               (uri (git-reference
-;;                     (url "https://github.com/openjdk/jdk18u")
-;;                     (commit (string-append "jdk-" version "-ga"))))
-;;               (file-name (git-file-name name version))
-;;               (sha256
-;;                (base32
-;;                 "1bv6bdhkmwvn10l0xy8yi9xibds640hs5zsvx0jp7wrxa3qw4qy8"))))
-;;     (native-inputs
-;;      `(("autoconf" ,autoconf)
-;;        ("openjdk17:jdk" ,openjdk17 "jdk")
-;;        ("pkg-config" ,pkg-config)
-;;        ("unzip" ,unzip)
-;;        ("which" ,which)
-;;        ("zip" ,zip)))
-;;     (arguments
-;;      (substitute-keyword-arguments (package-arguments openjdk16)
-;;        ((#:phases phases)
-;;         `(modify-phases ,phases
-;;            (replace 'fix-java-shebangs
-;;              (lambda _
-;;                ;; This file was "fixed" by patch-source-shebangs, but it requires
-;;                ;; this exact first line.
-;;                (substitute* "make/data/blockedcertsconverter/blocked.certs.pem"
-;;                  (("^#!.*") "#! java BlockedCertsConverter SHA-256\n"))))))))
-;;     (home-page "https://openjdk.java.net/projects/jdk/18")))
+(define-public openjdk18
+  (make-openjdk openjdk17 "18"
+                "1bv6bdhkmwvn10l0xy8yi9xibds640hs5zsvx0jp7wrxa3qw4qy8"))
 
 ;;; Convenience alias to point to the latest version of OpenJDK.
-(define-public openjdk openjdk17)
+(define-public openjdk openjdk18)
 
 (define-public icedtea icedtea-8)